Sketch won't Upload

Sorry to have to post such a tired old problem that has been well covered already but research doesn’t help. Here’s what I have tried so far to solve my problem of being unable to upload from Windows 10 Arduino IDE App to the Uno Wifi Rev 2. The problem is I get:
Sketch uses 1482 bytes (4%) of program storage space. Maximum is 32256 bytes. Global variables use 196 bytes (9%) of dynamic memory, leaving 1852 bytes for local variables. Maximum is 2048 bytes.
An error occurred while uploading the sketch.
then 10 of these: “avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00”
So far I:

  1. Checked that the Arduino is receiving power. It is. It’s actually running a sketch I was able upload using the online code IDE. The sketch prints “Hello World” to the serial monitor every 10 sec and it’s currently doing that. Problem is I can’t upload almost the same sketch (this one says “Hello PC” using the Arduino IDE App on the PC.
  2. Checked that the Arduino device driver is installed. Device manager lists the mEDBG Virtual COM Port (COM3) as being installed. Checked for updates and it’s current. Driver Provider: Atmel Corp. Driver Date: 6/14/2013; driver version: 6.0.0.1; Digital Signer: Arduino AG. “Windows has determined that the best driver for this device is already installed.”
  3. Checked that the COM port is not being used by the online-version of the IDE or any other program by closing all programs, unplugging the Arduino Wifi Rev 2 from the USB port for 10 seconds, then plugging it back in, then starting up only the Arduino App and try uploading the new Hello PC sketch. Still get the same error and the Arduino is still printing “Hello world” not “Hello PC” to the serial monitor.
  4. Other clues: on the PC IDE App the IDE:Tools:Board: says “Arduino Uno Wifi” – correct, but IDE:Tools:Port: says “COM3” and that’s it. While that is the correct (and only) port; on the Mac the IDE:Tools:Port is labeled with the port number followed by the board ID. One other difference is that on the Mac the IDE:Tools:Get Board Info: shows the correct board info. On the PC, IDE:Tools:Get board info: shows
    BN: Unknown board
    VID: 03EB
    PID: 2145
    SN: Upload any sketch to obtain it
    Ok, maybe once I get a sketch uploaded it will display the correct board info.
    I can’t go back to the Mac because of a different problem that forced me to the PC, namely the inability to install the Safari plugin for the Arduino Create Agent, which has been posted here but as yet unresolved. Thanks.

Hi @delucadana. Despite the similar names, the Arduino Uno WiFi Rev2 is very different from the Arduino Uno WiFi. This is the cause of the upload error you are having.

In order to use the Uno WiFi Rev2 in the Arduino IDE, you must first install its boards platform by following these instructions:

  1. Select Tools > Board > Boards Manager from the Arduino IDE’s menus.
  2. Wait for the update to finish.
  3. Scroll down through the list of available boards platforms until you see “Arduino megaAVR Boards”. Click on it.
  4. Click the Install button.
  5. Wait for the installation to finish.
  6. Click the Close button.
  7. Select Tools > Board > Arduino megaAVR Boards > Arduino Uno WiFi Rev2 from the Arduino IDE’s menus.

Now you can try uploading again.

Pert,
Fantastic! It works. I’ve been struggling with that for days.

One more question: What does this mean? It printed out after the upload.

avrdude: WARNING: invalid value for unused bits in fuse “fuse5”, should be set to 1 according to datasheet
This behaviour is deprecated and will result in an error in future version
You probably want to use 0xcd instead of 0xc9 (double check with your datasheet first).

I’m glad to hear it’s working now!

A few years ago, the developers of the AVRDUDE tool the Arduino IDE uses to upload sketches to the Uno WiFi Rev2 and other boards of the AVR architecture changed the way it handles unprogrammed fuse bits. That change broke compatibility with the previous fuse configurations. This was a difficult situation because Arduino is very focused on providing a stable experience to the users. The average Arduino user doesn’t want to be forced to make complex adjustments to fuse values in obscure configuration files. Many would prefer to remain blissfully unaware of the existence of configuration fuses so they can focus their attention on the less boring aspects of using microcontrollers.

So Arduino made a modification to AVRDUDE to allow it to continue to support the old style of fuse values in addition to the new ones. When it encounters the old style, it shows this warning, but if Arduino ever decides to remove support for the old values, they will be sure to update the fuse values in the official boards platforms in advance of that change.

So you can safely ignore this warning. It is expected and doesn’t indicate any problem.

Thanks for the help.

You’re welcome. I’m glad if I was able to be of assistance. Enjoy!
Per

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.