Sketchbook Folder Missing

I have been having trouble trying to get Arduino to run on Windows 7. No matter what I do I get the same error:

Sketchbook folder disappeared
The sketchbook folder no longer exists. Arduino will switch to the default sketchbook location , and create a new sketchbook folder if necessary. Arduino will then stop talking about himself in the third person.

I have tried:

  • Deleting and removing all traces and then reinstalling Arduino and Java
  • Given both programs full permissions
  • Run these programs as administrator

Where should the sketchbook folder be located?
What is it called?
What does it contain?

Maybe I can find it and see if it is hidden or else create it from scratch.

I’ve probably spent at least 20 hours searching for a solution on the web and trying things.

Any smart people out there that know how to fix this? Pleeeeeease?

Try looking in your recycling bin, if you're using a PC. I don't know what the Mac equivalent is, but check in that kind of area/folder.

leadfeather: Where should the sketchbook folder be located?

I believe the default is a directory under Documents. You can locate the folder wherever you'd like. Start Arduino. Click File then Preferences. The sketchbook folder is at the top of the dialog.

What does it contain?

The programs you write for the Arduino are called "sketches".

[quote author=Coding Badly link=topic=94551.msg710357#msg710357 date=1330637668]

leadfeather: Where should the sketchbook folder be located?

I believe the default is a directory under Documents. You can locate the folder wherever you'd like. Start Arduino. Click File then Preferences. The sketchbook folder is at the top of the dialog.

What does it contain?

The programs you write for the Arduino are called "sketches".

[/quote]

Problem is I can't get Arduino to start. I just get the error shown in my first post.

leadfeather: Problem is I can't get Arduino to start.

Ugh. Would have been nice to know that.

• Start Explorer. • Navigate to... C:\Users{YourAccount}\AppData\Roaming\Arduino\ • Open preferences.txt • Locate the sketchbook.path entry... sketchbook.path=C:\Projects\Arduino\Sketch • Change it to an existing location • Save and close the file • Try again to start the Arduino IDE

OK, after trying sooooo many things I finally got it working.

I changed this line in preferences.txt

settings.path=data

to

settings.path=data

With the same issue, I tried both fixes on this thread and still had no luck. I thought it might be an issue with spaces in the path name.

sketchbook.path=C:\Users\mike\My Documents\arduino

I tried quotes; sometimes that fixes this issue.

sketchbook.path="C:\Users\mike\My Documents\arduino"

Nope. Same problem. So I tried moving everything. I moved the entire "arduino" folder from the path noted previously up one level and changed the preferences.txt file to match.

sketchbook.path=C:\Users\mike\arduino

Things loaded up just beautifully. When opening a sketch, the dialog started in the wrong folder, but I was able to navigate where I needed to go and upload sketches to my Uno. I still don't know for sure if the space was the problem, but I got my stuff running. I hope this helps someone!

Coding Badly Global Moderator

Absolutely the right answer. Succinct and to the point of unerring accuracy. I modified my Sketch address by simply adding "Sketch" to the address presented and formed a file called "Sketch" at the location and; Bob's yer Uncle & Charlie's yer aunt!!!!

Cheers, and many of them Mr., Moderator, Chris Spreckley UK.