Skm53 gps module and demo code

PaulS:

do I have to reinstall TinyGps.h library?

Where did you get the version of TinyGps.h that you have? The latest version contains:

#if defined(ARDUINO) && ARDUINO >= 100
#include "Arduino.h"
#else
#include "WProgram.h"
#endif

which would, on 1.0+, ensure that the compiler is not even be looking for WProgram.h.

Paul, thanks!

I have downloaded the old version TinyGPS.h library. Now I got a more recently library version and it's working fine. thanks very much

$GPGSA,A,3,28,09,15,08,07,,,,,,,,5.36,5.27,0.99*0A $GPGSV,2,1,91,915,22,223,37 $GPGSV,22707,17,088,,103,124,,390,3,*4B $GPM25210.000,A30.869,S,0511.4,W,0.00,32.980913,,,A6 $GPGGA,215211.000,3002.3869,S,05113.2543,W,1,5,5.27,23.7,M,4.5,M,,*56 Latitude and longitude valid! Lat: -3003978 Lon: -5122090

I'm having the same problem, my module keeps on sending 0.00, 0.00. I tried it outside and inside but all in vain. ANy suggestions please?

I am trying to get latitude and longtitude datas from arduino uno via Skylab skm53 gps module.I have uploaded a demo code.The code owner says you will get sample outputs like this: Latitude : 30.330136 :: Longitude : 31.057404 Latitude : 30.330092 :: Longitude : 31.057339 But from my arduino I just saw in the serial monitor:

Latitude : 0.0000000 :: Longitude : 0.0000000 Latitude : 0.0000000 :: Longitude : 0.0000000

I have already included Libraries NewSerialsoft and TinyGPS but still i had no response from the arduino

please help me m really in a trouble

Don't forget GPS units don't work indoors unless you're close to a window. Have you tried taking it outside?

Hi, I've tryed to run this code:

include "TinyGPS.h"

include "SoftwareSerial.h"

define HEMISPHERE_PIN 13

define GPS_RX_PIN 4

define GPS_TX_PIN 3

TinyGPS gps; // create a TinyGPS object SoftwareSerial ss(GPS_RX_PIN, GPS_TX_PIN); // create soft serial object void setup() { Serial.begin(9600); // for debugging ss.begin(9600); // Use Soft Serial object to talk to GPS pinMode(HEMISPHERE_PIN, OUTPUT); digitalWrite(HEMISPHERE_PIN, LOW); // turn off LED to start } void loop() { while (ss.available()) { int c = ss.read(); Serial.write(c); // display NMEA data for debug } }

but ss.available is false. Where is the problem? Gps is connected to 5v pin and I'm tring it outside.

Thanks a lot

SoftwareSerial ss(GPS_RX_PIN, GPS_TX_PIN);

You have to connect the GPS RX pin to the Arduino TX pin, and vice versa. The SoftwareSerial statement sets up Arduino RX on the first pin number you pass, and TX on the second pin number you pass. Try this instead:

SoftwareSerial ss( GPS_TX_PIN, GPS_RX_PIN );

Cheers, /dev