Sloeber plugin fails to create project

I think I’m flogging a dead horse here but I guess there is no harm in asking…

I had to rebuild a Windows machine (two actually) so… clean installs of Windows 10, openjdk 12 and Eclipse (cpp) - Version: 2019-06 (4.12.0). Then added the Sloeber plugin. Try to create a new Arduino sketch, it gets to the point where the folder is created with a minimal(?) .project (only the name field contains data), and then throws an error “Failed to create project” and “java.lang.reflect.InvocationTargetException”. (I’ll attach the stack trace.)

I’ve tried several re-installs (different locations) adding other Eclipse components as it seems to be related to org.eclipse.cdt.managedbuilder.internal.core.Configuration if I’m reading the stack trace correctly.

Same results on both Windows machines, also upgraded (clean install) Eclipse on my Mac (Mojave) added Sloeber, same result.

As Sloeber seems to be heading into the sunset, I’m not really expecting to resolve this but I’d rather not have to switch to something else just now.

(Interestingly, if I import an Arduino project from my previous installation, I can edit, compile and upload apparently without issues.)

Any suggestions would be most welcome.

Regards,

jarsudsco

StackTrace.txt (12.3 KB)