SM5100 GPRS w/ Uno

Hi Guys

I'm having a problem with getting my SM5100 working on GPRS with my
Arduino Uno.

I'm powering the SM5100 and the Uno with a 12v 6a power supply, that's
wired directly into the +vcc and ground of the SM5100 and the power
socket on the arduino.
If I don't power the Uno & SM5100 with the same feed, it seems I need
a common ground otherwise I get gibberish on the serial line.
There's a common ground because both boards share a power feed.

The SM5100 is connected with two wires for pins 2+3 and I'm currently
using NewSoftSerial (am aware that a hardware uart is needed later for
reliable receive - but I can't find much detail on how to set that up)

At first I had issues getting the board to detect my sim card. It
wouldn't work with either of my two vodafone simcards, just returned
+SIND: 0 on startup.
Eventually I purchased a brand new 2 degrees sim for testing.
This sim gets detected and the board connects to the cell network.

n.b. I'm in NZ, and I'm using 2 degrees which is GSM900/1800 and I've
tried SBAND:4 and SBAND:9
4 GSM900&DCS1800
9 GSM850&GSM900&DCS1800

I've searched google and the sparkfun forums quite extensively, it
seem there's two commands to do a GPRS attach (AT+CGATT=1 and AT
+SATT=1,0) but both of them return "+CME ERROR: phone failure"

Here's a picture of my wiring, just in case that's somehow related:
http://ineedcoffee.co.nz/photo1.JPG and http://ineedcoffee.co.nz/photo2.JPG
My handwritten documentation of commands and expected responses:
http://ineedcoffee.co.nz/cellboard.txt

Here's an annotated log of me interacting with the device: http://ineedcoffee.co.nz/log.txt

As you can see in the log, everything appears to be working, except
the GPRS connection which always stays as +CGATT: 0 even if I try to
force an attach (which eventually errors, seems to take about 30
seconds)

I've tried this setup from two different locations (my house and my
office). I haven't yet tried it from home with the 6A supply, but I
used a 9V 3A supply from home last night with the same results.

Any help is appreciated, at first I thought it was a power issue but
with the 6A supply I think I've ruled that out.

Hi Agrath,

Did you ever get this issue resolved?
I'm facing the same issue and hit a wall with AT+CGATT=1 and AT +SATT=1,0

Thanks
Tony

Hi Tony,
I think I had faulty hardware.
I have since switched to the libelium shield

http://libelium.com/squidbee/index.php?title=New_GPRS_module_for_Arduino_(Hilo_-_Sagem)