Smart GPU and Windows 8 library. Not recognizing header file

HI Guys,

I seem to have run into a windows problem with getting the IDE to pickup the library’s header file.
If I unzip it to the library folder of Arduino installed on my PC and pick an example without changing anything I get an error that the variables such as width and so on is not declared.
If I follow the README and uncomment the lines for the GPU that I use and try to compile the same example the <SMARTGPU.h> files remains black and does not turn orange as normal.
If I compile it says several items were not declared.

Now If I do the same with my other PC running windows 7 i dont get the same problems and it compiles.
I tried setting all the security features on the files down and to unblock the file but no luck yet.

Does anyone maybe know where else I can do or change something?
I used IDE1.05 on both PC’s.

I re-installed Arduino and linked the library to the file.
Now it sees the header file but does not recognise some of the items.

Any idea where I should scratch for an answer?

"IMPORTANT : This library is created for the Arduino 1.5.2 Software IDE or newer"
Try with 1.5.6-R2 Beta or 1.5.7 Beta.

Before using your smartGPU2 board, go to smartGPU2.h file and uncomment the proper line under "user modifable" section:

For example: Arduino Due + SmartGPU 2 3.5", Arduino IDE 1.5.6-R2 Beta on Windows 8 Pro

/USER MODIFABLE***/
//-Uncomment your preferred smartGPU2 board(only 1 at time)----------------
//#define LCD160X128 //SmartGPU2 1.8" connected via SmartSHIELD
//#define LCD320X240 //SmartGPU2 2.4" connected via SmartSHIELD
//#define LCD320X240SH //SmartGPU2 2.4" directly mounted as Arduino Shield
#define LCD480X320 //SmartGPU2 3.5" connected via SmartSHIELD
//#define LCD480X272 //SmartGPU2 4.3" connected via SmartSHIELD
//#define LCD800X480 //SmartGPU2 7.0" connected via SmartSHIELD

//If using Arduino DUE please uncomment the next line - Remember to re-wire smartGPU2 TX and RX pins to the defined Serial port of Arduino
#define ARDUINO_DUE

//-SmartGPU2-Arduino RESET PIN definition
//-SmartSHIELD uses default Arduino pin p4 for Reset, if another pin is soldered in the SmartSHIELD(pin 7, 8 or 13), please modify here:
#define RESET 8 //Define for the RESET pin connected on the SmartSHIELD board(pin 7, 8 or 13)

//-Arduino serial port and AREF configuration using smartSHIELD
#ifdef ARDUINO_DUE //If arduino DUE is defined
#define SERIALPORT (Serial3) //(Serial2,Serial3), connect the smartGPU2 TX and RX pins to the defined serial port of Arduino
#define ARDUINOREFERENCE AR_DEFAULT
#else //Arduino UNO or similar
#define SERIALPORT (Serial)
#define ARDUINOREFERENCE DEFAULT //Define the AREF pin - Internal Analog reference as DEFAULT
#endif
/END OF USER MODIFABLE**/

I will try with another IDE Version as well, but i have 1.5R2 installed, which is the latest one before the Beta.
I use a UNO but it should at least compile??
Here is my .h file and the cahnges.

#ifndef SMARTGPU2_h
#define SMARTGPU2_h

#include <inttypes.h>

/USER MODIFABLE***/
//-Uncomment your preferred smartGPU2 board(only 1 at time)----------------
//#define LCD160X128 //SmartGPU2 1.8" connected via SmartSHIELD
//#define LCD320X240 //SmartGPU2 2.4" connected via SmartSHIELD
//#define LCD320X240SH //SmartGPU2 2.4" directly mounted as Arduino Shield
#define LCD480X320 //SmartGPU2 3.5" connected via SmartSHIELD
//#define LCD480X272 //SmartGPU2 4.3" connected via SmartSHIELD
//#define LCD800X480 //SmartGPU2 7.0" connected via SmartSHIELD

//If using Arduino DUE please uncomment the next line - Remember to re-wire smartGPU2 TX and RX pins to the defined Serial port of Arduino
//#define ARDUINO_DUE

//-SmartGPU2-Arduino RESET PIN definition
//-SmartSHIELD uses default Arduino pin p4 for Reset, if another pin is soldered in the SmartSHIELD(pin 7, 8 or 13), please modify here:
#define RESET 4 //Define for the RESET pin connected on the SmartSHIELD board(pin 7, 8 or 13)

//-Arduino serial port and AREF configuration using smartSHIELD
#ifdef ARDUINO_DUE //If arduino DUE is defined
#define SERIALPORT (Serial3) //(Serial2,Serial3), connect the smartGPU2 TX and RX pins to the defined serial port of Arduino
#define ARDUINOREFERENCE AR_DEFAULT
#else //Arduino UNO or similar
#define SERIALPORT (Serial)
#define ARDUINOREFERENCE DEFAULT //Define the AREF pin - Internal Analog reference as DEFAULT
#endif
/END OF USER MODIFABLE**/

Thanks for the help.

Silly mistake. Ran IDE 1.05 instead of 1.5.7. Now its working.