SmartEverything FOX stuck on upload

Hi all,

I just bought the SmartEverything FOX Board years ago which is Arduino compatible http://www.smarteverything.it/wp-content/uploads/2015/10/SmartEverything-User-Guide-Ver-1.01.pdf and simply tried to get started with it.

I am running on a windows 10 PC,

I can compile the sketches but I cannot upload sketches on it, when I try, it gets stuck on uploading, whether it is a basic script (blinkRBG) or even the default one with empty setup and loop methods, my laptop processor keeps running at 100% and nothing happens.
The board does not do anything, tx/rx leds do not flash. The program will remain uploading for an infinite time.
I cannot upload anything to the board with anything (tried on ACER laptop, DELL laptop and any PC)

I have tried to manually install some drivers from GitHub on both my computer and laptop but it does not seem to recognise the COM Port when I look at the device manager. The error window is as follows:
cannot complete the device driver installation wizard
Arrow (www.arow.com) Arrow USB Driver (for...) Install failed

When I try to upload, I only get the compiling logs:
Quote

processing.app.debug.RunnerException
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:152)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
at processing.app.SketchController.upload(SketchController.java:732)
at processing.app.SketchController.exportApplet(SketchController.java:703)
at processing.app.Editor$UploadHandler.run(Editor.java:2055)
at java.lang.Thread.run(Thread.java:748)
Caused by: processing.app.SerialException: Error touching serial port 'COM4'.
at processing.app.Serial.touchForCDCReset(Serial.java:107)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:136)
... 5 more
Caused by: jssc.SerialPortException: Port name - COM4; Method name - openPort(); Exception type - Port busy.
at jssc.SerialPort.openPort(SerialPort.java:164)
at processing.app.Serial.touchForCDCReset(Serial.java:101)
... 6 more

I am connecting directly from my board to my laptop through USB 3.0, I don't have USB2.0 plugs on my laptop, and I currently don't have any programmer device.

I tried with different versions of arduino IDE (1.6.4 1.6.5 nightly), same issue every time.
The IDE does not see my board connected to any COM PORT

E2984D5A-06F7-4DB6-A5A8-025B3887D08A.png

E2984D5A-06F7-4DB6-A5A8-025B3887D08A.png

First try turning OFF driver signing in windows 10 as it can on occasion cause its own issue.
Then install the drivers as ADMINISTRATOR and bypass any other warnings.
Thats should get you past the driver problem.

USB 3.x can for some unfortunate people cause random hardware issues and in that case the normal fix would be one of two things.

A. Install the correct driver for your hardware from the manufacturers site NOT from Microsoft !
B. Use a properly powered USB 2.0 hub between the hardware and the USB 3.x port.

Or both of the above.