So are the powers-that-be know the top menu is missing?

On some platforms the top menu of the forum is missing. Makes navigation the forum a bit tricky at times. I was thinking this place is pretty confusing 'till I looked at it on my iPone and found the missing menu bar.

Safari 11.2 has not top menu bar.

-jim lee

I had the same problem on my Mac - an upgrade to Safari 13.1.2 fixed it. It may have been the reboot/restart that came with it of course.

My iPad with Chrome still doesn’t show the top bar, but there it’s a blessing, leaving a bit more space for real content.

Hi @jimLee. Would you mind posting a screenshot?

Is it the entire teal bar, or only one layer of the teal bar?

Ha! Tough to get a picture of what is not there.

I mean the top bit with your picture and search that rolls up and down. The second bit, with the popup is always present.

90% of the time its just not there and sometimes I can get a peek at it scrolling past top. But then its white with just the picture. Not that I could click in it.

OK, that’s what I thought. Someone else had mentioned that specific problem in another thread (which I saw you already noticed), and I was just checking to see whether we had a dedicated thread about it.

It shows up with Firefox on the desktop but not Safari, I haven’t tried updating Safari, I’m kinda stuck with “legacy” apps so tend to avoid updating things that work… no, Tim, I will not throw away dozens of apps for whatever feature your latest OS provides. Until I have no choice.

And iPads seem to act differently depending on size. On my giant iPad I get the side scroll device, my assistant’s iPad regular size does not. Which is just more a “works better on the desktop than on the smart phone” kinda thing.

a7

@pert So as long as we’re on the subject. My Mac also doesn’t show bookmarked posts to me when looking at my “Activity” or “All” menus. It does show up on my iPhone. (How I know it was being missed) And yes I do have a bookmarked post.

-jim lee


Hi pret

screenshot as was requested

in the middle small screen , how it should look… big screen my screen on Win 7 FF 70. in the right upper corner yo can see I have no notifications of new message and etc features
how to fix this ?

Please try to open your browser in incognito mode (disabling all the extensions) and let us know if you still have issue.

If the problem disappears it means that there is some extension that is interfering with the site, if there is still the problem instead click F12 to open the browser console and check if there are errors in red

1 Like

No not disappears

still I have no top menu/badges/search/etc

win7 ff70

I’m not running Win7 any more but the latest version of FF (for Win10) is 88.0. Not sure if you can upgrade your browser.

but this confirms how unoptimized and unsuccessful the engine is on this forum …
AND
if I open for example this page Serial - Arduino Reference then I HAVE top menu :slight_smile:

so just need more QA and better codding before release new engine :wink:

This is a problem with the custom header but not with the Discourse core.

So to recap, the problems are on older browsers versions, for sure

  • safari 11.2
  • FF70

others?

1 Like

Safari 12.1.1 (MacOS Mojave 10.14.5)

a7

Could we just scrap the custom header? I always hated it anyway. The bottom part doesn’t really add anything useful.

-jim lee

So, it seems that the origin of the header problem on some browsers was actually due to the consent cookie banner (fixed).

Can someone try an hard refresh of the site and see if the issue disappears?

1 Like

ha :slight_smile: looks like somebody fixed… will keep finger on the pulse for a while

Yeah, it makes navigation a lot easier. AND it no longer goes up and down. Vast improvement loosing that little feature.

Good job!

-jim lee

@pert what is the policy for the bugs fixed here? Can we close the topic or do you let it auto-close by itself?

The previous policy was that people could edit the topic title to add a “[solved]” prefix when it was solved:

But that was very rarely followed, perhaps partly because it was not very convenient to do. That was all there has ever been.

My preference would be for the topic creator to use the :ballot_box_with_check: Solution button to mark the topic as solved. This would leave the topic open for continued discussion in case others are still having the problem.

2 Likes