Softbricked atmega328p the usual 000000 id issue,

Hi I need a little help using nick gammons tools...

I have a atmeger 328p that is currently softbricked... Its on a pro mini board and the board is soldered into my project.

I couldnt tell you how I managed to brick it, because im not really sure. i have tried to get this back to life using arduino as isp and an asp programmer. None of this want to talk to the chip. AVRdude wont proceed as it has an ID missmatch, the id returns the ID 000000 or 00fff00 problem...

I have checked the jumper cables and they all seem fine. Even changed them.

Now Because the board is soldered into my project I cant really isolate it. However the SPI pins are not being used and so there shouldnt be any interfering stuff going through those pins.

Someone mentioned Nick Gammons tools and so i did some googling and found this guide. http://www.gammon.com.au/breadboard

When i run the board detector sketch I get this dump from serial.


Atmega chip detector. Written by Nick Gammon. Version 1.20 Compiled on Aug 8 2018 at 16:31:18 with Arduino IDE 10805. Attempting to enter ICSP programming mode ...................................................... Failed to enter programming mode. Double-check wiring! Programming mode off.


So any idea what to do next?

Im pretty close to desoldering the atmega and replacing it with one off a healthy board.

try injecting clock. https://www.avrfreaks.net/forum/tutsoft-recovering-locked-out-avr

I saw that too, but i cant currently try it till one of the dedicated ISP programmers come in the post. Currently my only ISP is the arduino as isp...

Adafruit has a version of ArdinoISP that provides clock... https://github.com/adafruit/ArduinoISP

Thanks ill keep a note of that... I ended up de-soldering the chip and replacing it with a working correct fuse setup... But thanks for the link