Software RTC w/ Processing sync

Arduino 022 and Duemilanove with Processing 1.51 and current Time library Duem. attached to pc with usb (power/comm).

Upload example TimeSerial, start example SyncArduinoClock (with correct com#) on Processing and click display window clock syncs and everything is fine. Then I stop Processing disconnect then reconnect usb, start processing click display and no sync (but I do see the RX led flash each time I click display). Pressing the Duem. reset allows it to Sync until I cycle the usb connection. Is this normal? Would the UNO or the Arduino 1.0.1 environment allow me to sync without physically resetting? Any suggestions would be appreciated.

Thanks Rob

Same scenario as above except Arduino 1.0.1 environment.
No change with the Duem.
Mega 2560 works fine without physical reset. Haven’t tried with Arduino 022
An Uno , I am now seperated from, also worked but the setup was not the same. It was powered with its own supply and received its sync from another (powered) Uno that just sent anything it got from the usb to a soft serial connected to an RS 485 bus.
I tried powering the Duem. but it was the same (no sync without physical reset).
Since a reset “fixes” the Duem. it’s hard to point the blame at processing or the environment (Actually I could’t blame them even if it was their fault, they’re way too nice!).
It seems to me this may just be a hardware issue and perhaps posting in ‘Interfacing w/ Software on the Computer’ was not the correct place. Comments/suggestions?
I know that there are differences in the reset crt for the Duem., Uno and Mega but thats about all I know.