Solenoid

Hi everybody,

I activate the button of my Epson scanner with a solenoid and relay, works well for a while but now the solenoid is very weak. (Not enough force to push the button).
I was wandering why?
Help is appreciated

SOLENOID_RELAY.ino (310 Bytes)

How are you powering the solenoid? Is the solenoid homemade? If not, who is the manufacturer and what is the model number and what are the specifications? How much force is needed versus how much force are you getting? Solenoids usually pull; how are you getting pushing?

So many questions, so little information.

I power to solenoid with 12v 1.5A.
The solenoid is Chinese with 12v and 2A.

Sorry the force of solenoid is 20N and I am pushing the button

Hi,
Welcome to the forum.

Please read the post at the start of any forum , entitled "How to use this Forum".
OR
http://forum.arduino.cc/index.php/topic,148850.0.html.
Then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

How are you driving the solenoid?
Do you have a DMM to measure some circuit parameters?

Thanks.. Tom... :slight_smile:

The answers that I am getting are so short and so incomplete that I don't get it.

For example, I ask for the manufacturer and the model and I get told that it is Chinese.

I don't get it and I cannot help this way.

vaj4088:
The answers that I am getting are so short and so incomplete that I don't get it.

For example, I ask for the manufacturer and the model and I get told that it is Chinese.

I don't get it and I cannot help this way.

Neither can anyone else so you are not alone.

Ron