[Solucionado] Problemas con el arduino IDE

Buenas noches, hoy he reinstalado el arduino IDE desde ubuntu con el comando

sudo apt-get update && sudo apt-get install arduino arduino-core

Y desde que lo he hecho me da este error al intentar abrir el monitor serial y cargar un scretch a mi arduino:

processing.app.SerialNotFoundException: Puerto serial 'COM1' no encontrado. ¿Estás seguro que seleccionaste el correcto del menú Herramientas > Puerto Serial?
	at processing.app.Serial.<init>(Serial.java:191)
	at processing.app.Serial.<init>(Serial.java:92)
	at processing.app.SerialMonitor.openSerialPort(SerialMonitor.java:207)
	at processing.app.Editor.handleSerial(Editor.java:2481)
	at processing.app.EditorToolbar.mousePressed(EditorToolbar.java:353)
	at java.awt.Component.processMouseEvent(Component.java:6513)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4489)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:747)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:720)
	at java.awt.EventQueue$4.run(EventQueue.java:718)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:717)
	at org.GNOME.Accessibility.AtkWrapper$5.dispatchEvent(AtkWrapper.java:697)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Lo raro es que en donde se pueden cambiar el puerto serial (herramientas → puerto serial) me sale en gris y no puedo cambiar nada… A alguien le ha pasado?

PD: Ahora que me fijo, cada vez que lo abro me sale esto (imagen adjunta).

Captura de pantalla de 2016-02-16 00-15-26.png

Pongo la solución que propones :

sudo usermod -a -G dialout <my-username>

davisss:
Pongo la solución que propones :

sudo usermod -a -G dialout <my-username>

Donde ejecuto el comando este? porque no me da ningun resultado… :confused:

Buenas, ya esta arreglado, me faltaba ejecutar otra orden. Para futuros problemas son estas dos (la que decia el compi davisss y la otra)

sudo usermod -a -G dialout <my-username>

sudo chmod a+rw /dev/ttyUSB0

donde /dev/ttyUSB0 es la ruta del puerto serial que se utiliza, sale en el informe del error.

Muchas gracias y espero que sirva para futuros problemas.