Solutions - "Device not recognized", "System cannot find specified file.", etc.

I have spent no less than 20 hours trouble-shooting my installation issues with my Arduino Uno.

In the process I have run across no less than XXX threads on forums around the internet outlining problems and solutions very similar to mine. Here I will describe the fix to my problem and link to solutions provided by other people (which didn’t happen to work for me).

Here goes:

When I initially tried to install my drivers I had read enough to avoid the FTDI drivers. I pointed my computer to the correct /drivers/ folder of the latest release. The installation proceeded but halted at “System cannot find the specified file.” I tried every permutation possible, to include the solutions listed above, and failed. I finally spied that people were looking through “”. So I looked through it too.

This is what I found:

     flq:                                    Inf     : 'c:\windows\system32\driverstore\filerepository\arduino uno rev3.inf_x86_neutral_65ebaae8c82d2ccd\arduino uno rev3.inf'
!    flq:                                    Missing SourceDisksFiles/SourceDisksNames information from INF.
     flq:                                    Source root path based on Main INF
     flq:                                    SourceRootPath: 'C:\Windows\System32\DriverStore\FileRepository\arduino uno rev3.inf_x86_neutral_65ebaae8c82d2ccd'
     flq:                                    {FILE_QUEUE_COPY}
     flq:                                         CopyStyle      - 0x00002000
     flq:                                         {FILE_QUEUE_COPY}
     flq:                                              CopyStyle      - 0x00002000
     flq:                                              [color=red]SourceRootPath - 'C:\Windows\System32\DriverStore\FileRepository\arduino uno rev3.inf_x86_neutral_65ebaae8c82d2ccd'
     flq:                                              SourceFilename - 'usbser.sys'
     flq:                                              TargetDirectory- 'C:\Windows\system32\DRIVERS'
     flq:                                              TargetFilename - 'usbser.sys'[/color]
     flq:                                         {FILE_QUEUE_COPY exit(0x00000000)}
     flq:                                    {FILE_QUEUE_COPY exit(0x00000000)}
     inf:                               {Install Inf Section [DriverInstall.NT] exit (0x00000000)}
     dvi:                               Processing co-installer registration section [DriverInstall.NT.CoInstallers].
     inf:                               {Install Inf Section [DriverInstall.NT.CoInstallers]}
     inf:                               {Install Inf Section [DriverInstall.NT.CoInstallers] exit (0x00000000)}
     dvi:                               Co-installers registered.
     dvi:                               {Install INTERFACES}
     dvi:                                    Installing section [DriverInstall.NT.Interfaces]
     dvi:                               {Install INTERFACES exit 00000000}
     dvi:                          {Install FILES exit (0x00000000)}
     dvi:                     Default installer: Exit
     dvi:                {DIF_INSTALLDEVICEFILES - exit(0x00000000)} 18:04:08.330
     ndv:                Pruning file queue...
     dvi:                {_SCAN_FILE_QUEUE}
     flq:                     ScanQ flags=620
     flq:                          SPQ_SCAN_PRUNE_COPY_QUEUE
     flq:                          SPQ_SCAN_FILE_COMPARISON
     flq:                          SPQ_SCAN_ACTIVATE_DRP
     flq:                     ScanQ number of copy nodes=1
!    sig:                     GetNameSDInfo
!    sig:                     [color=green]Error 0: The operation completed successfully.[/color]
     flq:                     ScanQ action=200 DoPruning=32
     flq:                     ScanQ end Validity flags=620 CopyNodes=1
     dvi:                {_SCAN_FILE_QUEUE exit(0, 0x00000000)}
     ndv:                Committing file queue...
     flq:                {_commit_file_queue}
     flq:                     CommitQ DelNodes=0 RenNodes=0 CopyNodes=1
     flq:                     {SPFILENOTIFY_STARTQUEUE}
     flq:                     {SPFILENOTIFY_STARTQUEUE - exit(0x00000001)}
     flq:                     {_commit_copy_subqueue}
     flq:                          subqueue count=1
     flq:                          {SPFILENOTIFY_STARTSUBQUEUE}
     flq:                          {SPFILENOTIFY_STARTSUBQUEUE - exit(0x00000001)}
     flq:                          source media:
     flq:                              [color=red] SourcePath   - [C:\Windows\System32\DriverStore\FileRepository\arduino uno rev3.inf_x86_neutral_65ebaae8c82d2ccd]
     flq:                               SourceFile   - [usbser.sys][/color]
     flq:                               Flags        - 0x00000000
     flq:                          {SPFQNOTIFY_NEEDMEDIA}
     flq:                               {SPFILENOTIFY_NEEDMEDIA}
     flq:                               {SPFILENOTIFY_NEEDMEDIA - exit(0x00000000)}
     flq:                          {SPFQNOTIFY_NEEDMEDIA - returned 0x00000000}
!!!  flq:                          source media: SPFQOPERATION_ABORT.
!!!  flq:                          Error 2: The system cannot find the file specified.
     flq:                     {_commit_copy_subqueue exit(0x00000002)}
!!!  flq:                     FileQueueCommit aborting!
!!!  flq:                    [color=red] Error 2: The system cannot find the file specified.[/color]
     flq:                     {SPFILENOTIFY_ENDQUEUE}
     flq:                     {SPFILENOTIFY_ENDQUEUE - exit(0x00000001)}

Solutions that did not work.
I tried all of the following and whatever else I could think of. I hope that maybe these might be useful to people with similar problems to mine. << “Unknown Device.”;num=1287472095 << “Windows XP won’t recognise driver and install.” << “Arduino UNO Rev3 Windows 7 Unknown Device - SOLVED! (for me at least)” “Unknown Device.” << “Unknown Device.” >> “Windows Vista fails to install driver for UNO”

My solution.
After I spotted the “file not found” in the install log I decided that maybe I ought to hunt down the missing file “usbser.sys”. I had to grab an install disk for Windows 7 and hunt around its innards to find it. Once I found it I pasted it into all of the locations that I could see in the log file.

Then I ran my install again and viola! It worked!

I have included the “usbser.sys” for those who may need it. If you don’t trust my file, grab a Windows 7 install disc and 7zip and mine it out of there (open install.wim >> Windows\System32\DriverStore\FileRepository\mdmcpq.inf_x86_neutral_1b9e317b2982c778".

I hope this helps people!

usbser.sys (27 KB)

Where did you buy your Uno from?

I bought my Uno from RadioShack. It came in a "starter kit".

Thanks for tracking this down and posting your solution!

Just wanted to give you my thanks for the solutions posted. After about 6 hours trying to solve the "unknown device" issue for my new arduino UNO 3rev, I read your post. For me, the second to last suggestion from the adafruit forum posted by yetiman worked:

"I had the same problem but found a solution. Go to the 'unknown device' in device manager. Open it's properties and select 'update driver'. Choose to browse for it, then select installed driver, then 'have disk'. Browse for the arduino installation directory and choose the 'arduino UNO.inf' driver in the drivers folder. Click through the rest of the promts and usual warnings about unsigned drivers. Voila."

without your help i would still be stranded!!!

Thank you so much, zog34, for posting this! Your solution didn’t work for me, but your approach did and I wanted to post how I got it working for anyone else unfortunate to have to deal with this.

Adding usbser.sys in all the places it was missing like zog34 didn’t work for me because the location being referenced didn’t exist either. Sifting through, I discovered that C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_fbc4a14a6a13d0c8 was wasn’t in my system. The code below shows the particular error preventing driver installation.

I found the folder in the Windows 7 instal disk and put it where it belonged. It came with usbser.sys inside. Once in place, the driver installation went as expected. Up and running!

     flq:                          {SPFILENOTIFY_STARTSUBQUEUE}
     flq:                          {SPFILENOTIFY_STARTSUBQUEUE - exit(0x00000001)}
     flq:                          source media:
     flq:                               SourcePath   - [C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_fbc4a14a6a13d0c8]
     flq:                               SourceFile   - [usbser.sys]
     flq:                               Flags        - 0x00000000
     flq:                          {SPFQNOTIFY_NEEDMEDIA}
     flq:                               {SPFILENOTIFY_NEEDMEDIA}
     flq:                               {SPFILENOTIFY_NEEDMEDIA - exit(0x00000000)}
     flq:                          {SPFQNOTIFY_NEEDMEDIA - returned 0x00000000}
!!!  flq:                          source media: SPFQOPERATION_ABORT.
!!!  flq:                          Error 2: The system cannot find the file specified.
     flq:                     {_commit_copy_subqueue exit(0x00000002)}
!!!  flq:                     FileQueueCommit aborting!
!!!  flq:                     Error 2: The system cannot find the file specified.
     flq:                     {SPFILENOTIFY_ENDQUEUE}
     flq:                     {SPFILENOTIFY_ENDQUEUE - exit(0x00000001)}

It’s worth keeping these resources together. I also just found another forum post that solved the same problem as mine here:,65956.0.html

Thank you so much for this post, I had the same problem trying to install my Arduino Mega 2560 on Windows 8.1.

I tried, but I now realized that it’s covering an old problem with unsigned drivers, so that obviously didn’t help. I’ll solved it using your post, however I want to post a quick summary for anyone with Windows 8.1 (probably the same for Win8) having the same problem.

How to fix this for Windows 8.1 (and probably Windows8 ) - Short Version

  • Search for usbser.sys on your Windows drive, if you find it, copy it
  • If you can’t find it, use the attached file
  • Copy the file to C:\Windows\System32\drivers\ & C:\Windows\INF\
  • Reinstall the drivers using the Windows hardware manager and the files supplied with the Arduino IDE under drivers
  • Have fun!

How I found and fixed the problem [/b][/u]

  • I first analyzed the last entry (as I didn’t try to install anything else) in which can be found under *C:\Windows\Inf*
    Just scroll all the way down, my entry said
    "No class installer for 'Arduino Mega 2560' "
    and a little bit further down
source media: SPFQOPERATION_ABORT (C:\Windows\INF\usbser.sys). 
Error 2: The system cannot find the file specified.

as well as

source media: SPFQOPERATION_ABORT (C:\Windows\System32\drivers\usbser.sys). 
Error 2: The system cannot find the file specified.
  • I copied the usbser.sys file that posted above here to those locations and for a second it looked like it might work, but in the end it didn’t
  • I again checked, now with the follwing error
Error 0xe0000234: Driver is not intended for this platform.
  • That rung a bell, as the supported usbser.sys file is from Windows 7. I just started a search for “usbser.sys” on my C: drive and, voila, found “my own” usbser.sys file under C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_e5cc5b49b7268c05 . I am pretty sure that this is some kind of temp folder, but you can probaly find one on your windows drive without having find your windows install dvd…
  • I just copied the files to C:\Windows\System32\drivers\ and C:\Windows\INF, replacing the old files and now I was able to update/install the drivers using the windows hardware manager

usbser.sys (32.5 KB)


Thanks so much to r0oland and zog34,

It was the Solution,

I dont know why the USBSER.SYS is lost but it is so,

your solution was faster and easyer than any other.

Best regards


Worked for me also (Windows 8.1) with an UNO. I was able to find a Windows 8.1 version of usbser.sys in the c:\Windows\System32\drivers.

Thanks so much for posting this.

Funny thing..when I plugged in a second Arduino Uno board in...the exact same problem occurred. The UNO showed up in the device driver as an Unknown Device again.

Went back to the first Uno board and it was still working correctly.

I wonder if I will have to do this for each of my Uno boards?

Windows XP

Hi For me what it did work, was to create directory mdmcpq.inf_x86_neutral_9f203c20b6f0dabd within C:\WINDOWS\system32\DRVSTORE\ and put this file usbser.sys overthere.

By the way reinstallation of this USB port drives me crazy each time.

best regards GM


I have a W7 laptop that lost the capability to communicate with my UNO after doing some Microsoft updates ~5/15/2015. I found the usbser.sys in the two folders and then downloaded and copied the file from above into both folders.

Then I plugged in my UNO and opened the Arduino software. The TOOLS>Port was still grey. I then opened Device manager and there are no 'UNO' type devices or broken ports shown. I right clicked my computer and had it search for new hardware. Still nothing.

I am pulling my hair out.

Can any one suggest how to fix this issue?

Thanks for your help in advance!

hello :'( :'( :'( :'( i have a arduino mega2560. my board work good and it hasn't any problem. i program it by arduino 1.6.5 and it work good. i decided to program my arduino by MATLAB. but when i write "a=arduino ( 'com8' , 'mega2560' ) my board No longer worked.when i want to upload my program by arduino 1.6.5 i see the error "The system cannot find the file specified". PLEASE HELP ME!!

Hi , I have the same problem of 'system cannot find the file specified' .I tried the solution recommended by rOoland .I pasted the usber.sys file in C:\Windows\System32\drivers\ & C:\Windows\INF\ but still the same problem occured. I could not upload my project on my arduino uno and the software again says 'the system cannot find the file specified. I am not understanding what to do now . I am in need of some experienced guys like you . HELP !!!!!!!

This is the error message I received.Maybe this would help.

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes. Cannot run program “REMOVE/bin/avrdude”: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessBuilder.start(
at cc.arduino.packages.Uploader.executeUploadCommand(
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
at cc.arduino.UploaderUtils.upload(
Caused by: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.(
at java.lang.ProcessImpl.start(
at java.lang.ProcessBuilder.start(
… 9 more

I was having issues in getting Windows 10 to recognize and install the driver for a Mega 2560 clone.

I followed your tip about searching for the usbser.sys on my own system (Windows 10) and it came right up. Thanks a ton!! :)

This worked for me.

I thank you r0oland because you gave me the possibility to download a file of which I was becaming fool to find!