[Solvd] Can't upload sketches on Due: bossac: extra arguments found

Hi,

I have a problem that I wasnt able to solve so far. Since today I cant upload any sketches to my Arduino Due with the web editor. The Error message:

Flashing with command:/home/porklemon/.arduino-create/arduino/bossac/1.6.1-arduino/bossac --port=ttyACM0 -U false -e -w {upload.verify} -b /tmp/arduino-create-agent667841717/sketch_oct3a.bin -R

bossac: extra arguments found

I have this problem on Linux and Windows, so I assume the problem isn't my fault.

I'm able to upload the sketch manually over the console when I remove the {upload.verify} part.

Any idea how to fix this if this isnt a serverside error?

I don't think there's anything you can do. Just use the standard Arduino IDE for now and check back with the Arduino Web Editor occasionally to see if they've gotten it fixed yet.

Hello, could you please try again and let us know if the error is still there?

We tested again and this issue should be definitively solved

Hello,

this issue seems to be back again or isn't solved. I'm using the Arduino web editor, Arduino DUE (Programming port) and already the basic blink example sketch fails to upload. I also tried Firefox and Chrome, including reinstall of the plugin, still no success:
...
/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-ar rcs /tmp/508095940/build/core/core.a /tmp/508095940/build/core/wiring_digital.c.o

/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-ar rcs /tmp/508095940/build/core/core.a /tmp/508095940/build/core/wiring_pulse.cpp.o

/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-ar rcs /tmp/508095940/build/core/core.a /tmp/508095940/build/core/wiring_pulse_asm.S.o

/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-ar rcs /tmp/508095940/build/core/core.a /tmp/508095940/build/core/wiring_shift.c.o

Archiving built core (caching) in: /tmp/core/core_arduino_sam_arduino_due_x_dbg_6e18a96b2f6e1a733d0d079e7d8e383a.a

Linking everything together...

/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-gcc -mcpu=cortex-m3 -mthumb -Os -Wl,--gc-sections -T/home/builder/.arduino15/packages/arduino/hardware/sam/1.6.12/variants/arduino_due_x/linker_scripts/gcc/flash.ld -Wl,-Map,/tmp/508095940/build/Blink.ino.map -o /tmp/508095940/build/Blink.ino.elf -L/tmp/508095940/build -Wl,--cref -Wl,--check-sections -Wl,--gc-sections -Wl,--entry=Reset_Handler -Wl,--unresolved-symbols=report-all -Wl,--warn-common -Wl,--warn-section-align -Wl,--start-group -u _sbrk -u link -u _close -u _fstat -u _isatty -u _lseek -u _read -u _write -u _exit -u kill -u _getpid /tmp/508095940/build/sketch/Blink.ino.cpp.o /tmp/508095940/build/core/variant.cpp.o /home/builder/.arduino15/packages/arduino/hardware/sam/1.6.12/variants/arduino_due_x/libsam_sam3x8e_gcc_rel.a /tmp/508095940/build/core/core.a -Wl,--end-group -lm -lgcc

/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-objcopy -O binary /tmp/508095940/build/Blink.ino.elf /tmp/508095940/build/Blink.ino.bin

/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/4.8.3-2014q1/bin/arm-none-eabi-size -A /tmp/508095940/build/Blink.ino.elf

Sketch uses 10692 bytes (2%) of program storage space. Maximum is 524288 bytes.

Programming with: Serial

Restarting in bootloader mode

Get port list before reset

[COM5]

Touching port COM5 at 1200bps

Set DTR off

Flashing with command:C:/Users/pwilhelm/.arduino-create/arduino/bossac/1.8.0-48-gb176eee/bossac.exe -i -d --port=COM5 -U false -e -w -b C:/Users/pwilhelm/AppData/Local/Temp/arduino-create-agent420942292/Blink.bin -R

bossac: extra arguments found

Try 'bossac -h' or 'bossac --help' for more information

patrickADI:
this issue seems to be back again or isn't solved.

What you are experiencing is actually a new issue that is a bit different from the original one reported in this thread, even though it results in the same error message. I have reproduced the issue and notified the Arduino Web Editor team about it. Someone will post on this thread once it has been resolved.

Thanks for reporting this patrickADI!

Up !

Problem still remaining at april 24 2019.

@Marc Lantelme

Does your problem relate to a DUE or a different board ?
Please read the sticky posts at the top of this section and add more details please as a “mee too” question will not get much help without it.

Bob.