<Solved> Arduino as ISP with ATTINY 84a

Hi, all!

I've been following this tutorial to a T. It simply guides the user to program an ATTINY using the Arduino Uno as an ISP. It's been pretty smooth sailing so far.

However, now that I am finally trying to upload the code to the ATTINY, I can't get away from the AVR Dude errors. I have tried resetting it at different times, removing the capacitor between RESET and GROUND, and other troubleshooting methods online and none seem to work.

I'm using a mac currently with IDE v 1.6.0

The errors:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding

Any more troubleshooting ideas?

Thanks! - Runningman

Are you using recent version of the core?

Also, make sure the Arduino as isp sketch is uploaded, and the right com port is selected, and auto reset is disabled on the uno (typically by putting 10uf cap between reset and ground)

What is the core?

The Arduino ISP sketch is indeed uploaded, the capacitor is wired correctly, and the correct com port is selected.

The Arduino-Tiny file you downloaded and extracted to the hardware folder in your sketchbook.

The core contains pin and board definitions. 1.0.x cores are not compatible with 1.6.x, and vice versa. A core that takes advantage of 1.6.x can also use submenus so you don’t have to modify boards.txt, but instead pick the options from menus. (the cores linked in my sig do that, but don’t have support for board manager easy installation yet)

I believe I actually am using the correct core because this is the menu I get.

Would you suggest I try your cores? How might I install them?

Oh, nice - that looks like a recent core, that's not the problem.

I fin dit odd that I've searched all over and that there are so many reasons for these AVR errors...

I'm using a mac currently with IDE v 1.6.0

Note there is a core for either version 1.0 ore 1.5xx

You will need the last one:

https://code.google.com/p/arduino-tiny/downloads/detail?name=arduino-tiny-0150-0020.zip

Guys,

Thank you so much for your time. For some reason, in every tutorial I took, I managed to somehow overlook actually burning the boot loader :stuck_out_tongue:

Thanks again!