[solved] Arduino Ide 1.5.3 for Intel Galileo won't start

Hi,

I'm quite new when it comes to microcontrollers and Arduino, however I have been working a bit with the Arduino Duemlianove. I'm also new on this forum so if i have posted in the wrong place or should have done it any other way please feel free to comment on it and I will keep that in mind for future posts.

Now I have bought an Intel Galileo board and I am trying to get the IDE for the Galileo board to run (1.5.3), which i downloaded from: https://communities.intel.com/docs/DOC-22226. I have been following the "Getting started guide" which can be downloaded from the same webpage above.

I have gotten to the point where I have installed the drivers for the Galileo on my windows 7 x64 system and I am now trying to start the IDE in order to update the firmware and uploading my first sketch. The problem is, when I start the arduino IDE the welcome screen appears but then it suddenly disappaears and nothing more happens. After the welcome screen is done i guess the main window should appear where you can write and upload code to the arduino, but it doesn't.

I have googled on this and found some other threads where people have had the same type of problem, for instance: http://forum.arduino.cc/index.php/topic,186529.0.html and https://github.com/arduino/Arduino/issues/1525. I have tried opening the arduino IDE through the command prompt as someone suggested, and also tried installing and opening the nightly build, however without any result.

Do anybody know how to solve this? Experienced the same type of problem? Help is greatly appreciated!

I have found the solution for this problem. It actually have something to do with the locale setting of the system you are using. It has to be set to english (US). I fixed this by creating a .bat file in the arduino-1.5.3 catalogue with the following command lines:

cd C:\arduino-1.5.3 java\bin\java -Duser.language=en -Duser.region=US -Xms128m -Xmx128m -classpath "lib;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar;lib\commons-exec-1.1.jar" processing.app.Base

where "C:\arduino-1.5.3" is the Arduino IDE location. This opens up the Arduino IDE. Hopefully this problem will be fixed in future releases of the Arduino IDE for Galileo.

Many Thanks! Have been bashing my head to the keyboard when not getting this Arduino IDE for Galileo to work. I have no idea what the commandline does, but it works!

It isn't fixed yet.... And Gen 2 is comming.

Hi all, I also find the solution, what you need do is to change the format from the other to English (US) as bellow:
Goto: Control Panel–>Clock, language, Region -->Region and Language–>Change the Location–>Formats, then change to English (US)