[solved] Arduino IDE 1.6.1 Wont run

Hi,
I have tried to get the 1.6.1 IDE to run, the splash screen appears for a brief moment then disappears.

My current version 1.6.0 runs fine and I also tried the arduino-nightly 1.6.2 which also runs okay.

I re-downloaded 1.6.1 in the zip and the installer formats both act in the same way.

I’m running Windows 7 Home Premium 64 bit.

I normally install manually using the zip file, and today was the first time that I tried the installer.

I have temporally moved back to 1.6.0.

Regards Terry

Please try running it from the command line using arduino_debug and paste here the error message

Hi here is the error that I get whilst trying to start Arduino 1.6.1:-

C:\Arduino\arduino-1.6.1>arduino_debug
Error occurred during initialization of VM
Could not reserve enough space for 1048576KB object heap

Ok, good news is that it has already been fixed, bad news is that it will be part of 1.6.2. For now, you can edit file arduino.l4j.ini (same folder of arduino.exe) and change -Xmx1024M to -Xmx512M If you want to run the IDE with arduino_debug, change arduino_debug.l4j.ini in the same way

:grinning: Thank you Federico for the solution, it worked okay. Regards Terry