[SOLVED] Arduino in circuit: Can´t upload sketches

Hi, im an electronics worker and experienced in microchip microcontrollers. I started Arduino for simplicity and information access. So far i managed to get most experiments to work. Now i wanted to build something big with it. I just finished wiring my audio spectrum analyzer but i cant get the arduino to receive sketches. I have to debug the board and i need the arduino to do that. But its impossible to get the chip out of my circuit to upload sketches in the unoR3 board as i already damaged the legs of the ic. In the uno board it uploads without problems.
Its an arduino with internal clock 8MHz as described here.
Pins 0,1 and 2 only are connected to the uno board and left unmentioned in the sketch. Initially a 10k pullup was connected to reset but now its snipped for a fix attempt including a 100nF cap in between reset.
Pins 3 to 10 are configured as outputs but connect only to inputs on shift registers. Pins 11 & 12 are INPUT_PULLUP, A0 & A1 OUTPUT an A2 INPUT for analogRead.
But that schouldnt affect upload, since my sketch isn´t running during upload.
Fail: "avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x09"
I´ve checked resistance from uno board socket to ic pin. I´ve analyzed signals on RX & TX during upload. TX is HIGH without signal.
Is there anything wrong with my wiring? Did i overload any pins necessary for upload? Or is wiring in circuit different from simple breadboard circuits?

In Circuit Serial Programming (ICSP)??

Only Sketch uploading. I programmed it seperately successfully.

What, exactly, do you think sketch uploading is, if not programming.
Uno uses a uc with a boot loader installed (programmed in) to upload (boot strap) the sketch (problem program) and start executing instructions.

You use ICSP to program a uc (in circuit) without the IDE (program in, or 'Load' the HEX file created by your Assembler/compiler). doing so will wipe out the boot loader code, if installed.

You ain't making a whole lot of sense, partner.

Programming Microchip PICs is more like ICSP than using the Arduino IDE.
If you are bending and/or breaking IC legs, I question your experience with uc's, or suggest you go a lot slower.

A) You have not bothered to provide the model of MCU you are using. ATtiny84? ATMEGA328P-PU?
B) No actual schematic...
C) Not confirmed you have bootloaded the device sucessfully.

If you use a botloader, isolate Rx and TX with jumpers or DIP switches. Attach serial-USB with jumpers off. Recap jumpers to use the update.


Im so sorry for wasting your time. I did a mistake in my circuit. I once had problems in the past with programming bootloader to arduino. I solved that with updating IDE. I thought the arduino was blocked in uploading by some circuitry but it was blocked by my rushing.
As i said, Apologies!