[SOLVED]Arduino-mk on Rasberry Pi

I am trying to upload sketches from my raspberry pi with arch Linux installed to my Arduino Uno.
The same process worked on my laptop but I can't seem to make it work on my PI.

void setup(){
	pinMode(13, OUTPUT);
	Serial.begin(9600);
}

void loop(){
	digitalWrite(13, HIGH);
	delay(100);
	digitalWrite(13, LOW);
	delay(100);
	Serial.println("Hello world");
}
 [alarm@alarmpi sketchbook]$ cat Makefile
ARDUINO_DIR = /home/alarm/apps/arduino/
ARDUINO_PORT = /dev/ttyACM*
BOARDS_TXT = /home/alarm/apps/arduino/hardware/arduino/avr/boards.txt

USER_LIB_PATH = /home/alarm/sketchbook/libraries
BOARD_TAG = uno

include /home/alarm/Arduino-Makefile/Arduino.mk
[alarm@alarmpi sketchbook]$ make
-------------------------
Arduino.mk Configuration:
- [AUTODETECTED]       CURRENT_OS = LINUX 
- [USER]               ARDUINO_DIR = /home/alarm/apps/arduino/ 
- [COMPUTED]           ARDMK_DIR = /home/alarm/Arduino-Makefile (relative to Common.mk)
- [AUTODETECTED]       ARDUINO_VERSION = 185 
- [DEFAULT]            ARCHITECTURE = avr 
- [DEFAULT]            ARDMK_VENDOR = archlinux-arduino 
- [DEFAULT]            ARDUINO_SKETCHBOOK = /home/alarm/sketchbook 
- [BUNDLED]            AVR_TOOLS_DIR = /home/alarm/apps/arduino//hardware/tools/avr (in Arduino distribution)
- [COMPUTED]           ARDUINO_LIB_PATH = /home/alarm/apps/arduino//libraries (from ARDUINO_DIR)
- [COMPUTED]           ARDUINO_PLATFORM_LIB_PATH = /home/alarm/apps/arduino//hardware/archlinux-arduino/avr/libraries (from ARDUINO_DIR)
- [COMPUTED]           ARDUINO_VAR_PATH = /home/alarm/apps/arduino//hardware/archlinux-arduino/avr/variants (from ARDUINO_DIR)
- [USER]               BOARDS_TXT = /home/alarm/apps/arduino/hardware/arduino/avr/boards.txt 
- [USER]               USER_LIB_PATH = /home/alarm/sketchbook/libraries 
- [DEFAULT]            PRE_BUILD_HOOK = pre-build-hook.sh 
- [USER]               BOARD_TAG = uno 
- [COMPUTED]           CORE = arduino (from build.core)
- [COMPUTED]           VARIANT = standard (from build.variant)
- [COMPUTED]           OBJDIR = build-uno (from BOARD_TAG)
- [COMPUTED]           ARDUINO_CORE_PATH = /home/alarm/apps/arduino//hardware/archlinux-arduino/avr/cores/arduino (from ARDUINO_DIR, BOARD_TAG and boards.txt)
- [DETECTED]           MONITOR_BAUDRATE = 9600  (in sketch)
- [DEFAULT]            OPTIMIZATION_LEVEL = s 
- [DEFAULT]            MCU_FLAG_NAME = mmcu 
- [DEFAULT]            CFLAGS_STD = -std=gnu11 
- [DEFAULT]            CXXFLAGS_STD = -std=gnu++11 
- [COMPUTED]           DEVICE_PATH = /dev/ttyACM* (from MONITOR_PORT)
- [DEFAULT]            FORCE_MONITOR_PORT =  
- [AUTODETECTED]       Size utility: AVR-aware for enhanced output
- [COMPUTED]           BOOTLOADER_PARENT = /home/alarm/apps/arduino//hardware/archlinux-arduino/avr/bootloaders (from ARDUINO_DIR)
- [COMPUTED]           ARDMK_VERSION = 1.6 
- [COMPUTED]           CC_VERSION = 4.9.2 (avr-gcc)
-------------------------
mkdir -p build-uno
/home/alarm/apps/arduino//hardware/tools/avr/bin/avr-g++ -x c++ -include Arduino.h -MMD -c -D__PROG_TYPES_COMPAT__ -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=185 -DARDUINO_ARCH_AVR -I/home/alarm/apps/arduino//hardware/archlinux-arduino/avr/cores/arduino -I/home/alarm/apps/arduino//hardware/archlinux-arduino/avr/variants/standard    -Wall -ffunction-sections -fdata-sections -Os -fpermissive -fno-exceptions -std=gnu++11 -fno-threadsafe-statics -flto -fno-devirtualize -fdiagnostics-color=always blinky.ino -o build-uno/blinky.ino.o
cc1plus: fatal error: Arduino.h: No such file or directory
compilation terminated.
make: *** [/home/alarm/Arduino-Makefile/Arduino.mk:1299: build-uno/blinky.ino.o] Error 1

Is anyone successfully using the Arduino.mk file to compile and upload sketches on there raspberry pi?
Thanks for any help.

I noticed a few of the [COMPUTED] paths were incorrect. Specifically, the directory archlinux-arduino needed to be changed to arduino. I was able to get things working with the following Makefile:

ARDUINO_DIR = /home/alarm/apps/arduino
ARDUINO_PORT = /dev/ttyACM*
BOARDS_TXT = /home/alarm/apps/arduino/hardware/arduino/avr/boards.txt
ARDUINO_CORE_PATH = /home/alarm/apps/arduino/hardware/arduino/avr/cores/arduino
ARDUINO_PLATFORM_LIB_PATH = /home/alarm/apps/arduino/hardware/arduino/avr/libraries
ARDUINO_VAR_PATH = /home/alarm/apps/arduino/hardware/arduino/avr/variants
BOOTLOADER_PARENT = /home/alarm/apps/arduino/hardware/arduino/avr/bootloaders


USER_LIB_PATH = /home/alarm/sketchbook/libraries
BOARD_TAG = uno

include /home/alarm/Arduino-Makefile/Arduino.mk

When uploading the sketch I get the following error:

make[1]: Entering directory '/home/alarm/sketchbook'
/home/alarm/apps/arduino/hardware/tools/avr/bin/avrdude -q -V -p atmega328p -C /home/alarm/apps/arduino/hardware/tools/avr/etc/avrdude.conf -D -c arduino -b 115200 -P /dev/ttyACM0 \
		-U flash:w:build-uno/sketchbook.hex:i
/home/alarm/apps/arduino/hardware/tools/avr/bin/avrdude: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory
make[1]: *** [/home/alarm/Arduino-Makefile/Arduino.mk:1571: do_upload] Error 127
make[1]: Leaving directory '/home/alarm/sketchbook'
make: *** [/home/alarm/Arduino-Makefile/Arduino.mk:1559: upload]

It seems the avrdude that is packaged with the arduino IDE is looking for libtinfo.so.5

The following shows:

[alarm@pi $] find /lib /usr/lib -name 'libtinfo*'
/usr/lib/libtinfo.so.6
/usr/lib/libtinfo.so

I do not have libtinfo.so.5 on my system. Anyone have any suggestions? I am going to read up on avrdude in the meantime. Thanks.

I installed avrdude with pacman.
The following worked:

[alarm@pi sketchbook]$ avrdude -q -V -p atmega328p -D -c arduino -b 115200 -P /dev/ttyACM0 -U flash:w:build-uno/sketchbook.hex:i

Now I can compile sketches on my ArchPi and upload them to my Arduino Uno.