[Solved]Arduino Nano IOT 33 with no connection on Linux

Hello, I am new to this community and I am seeking some help.

I recently started to code with an Arduino without any problem on linux and decided to buy the arduino nano 33 Iot.

However I can't get it to connect to my linux machine.

This is what I observed and tried.

  • When the board is plugged I have nothing with the command dmesg about the board and no TTYACM0 is /dev/
    -The power is powered green light on and the orange light is blinking with a frequency +-1hz
  • A quick test on a windows machine was similar
    -I tried to change the usb wire, it is still the same

edit I forgot to install the librairies for the nano...
but still no TTYACM0
Hope these help you to pin point my problem

Thank you the help

And the third USB cable made the all thing works.
Third times the charm.

Should I delete the post?

Thanks for taking the time to post an update with your solution redox7676! I'm glad to hear it's working now.

You should not delete your post because it can help other people who have the same problem and find this thread while searching for a solution.