[SOLVED] Arduino Nano V3 not working. With VIDEO (pls watch)

I bought this from an Ebay seller in January 2012 and he sent me the 2009 version. Tried to upload a blink sketch but it failed. Installed the correct driver, chose the correct COM port and chose the correct board. The RX led blinks 3 times when im trying to upload, and then fails. If I open the serial monitor and simply send a command, the RX led blinks once.

I contacted the seller but he insisted that he tested the board before sending it out and it was working. I did not do anything to it and even hold it by its side (to avoid static damage). And the package arrived in a well packaged box.

I emailed gravitech two weeks ago but there was no response. I read from some post that the 2009 version has issues and people managed to send the unit back to gravitech for replacement.

Please help me. Any inputs will be appreciated. Thank you for watching the video and reading this.

Could you give the ebay link? It seems mine is te same one and is behaving the same way!

Is your video blurry or was the labeling sanded off of the atmega?

Sorry for the late reply guys.

@vishalapr,
the link is here. http://cgi.ebay.com.my/ws/eBayISAPI.dll?ViewItem&item=130618080422
Thanks

@James C4S,
the arduino came like that, the words on the Atmega chip is like washed off. Thanks

In the listing it says: "Will NOT Ship To ITALY". That should be a pretty big clue that you're dealing with a clone. I wouldn't expect any support from Gravitech, since you didn't buy anything from them.

Additionally, the "washing" or "sanding" off of the text on the chip says why. Not only did the seller sell you a clone of the board, whoever built it used knock-off parts as well. When the text is sanded off of an IC it is generally for two reasons 1) the IC isn't what it is claimed to be or 2) it was rejected during manufacturing.

So someone built the board with bad parts. You might try selecting the ATmega168 board in the IDE to see if you have a 168. If that doesn't work, then you've just paid a $15 "if the price is too good to be true" lesson.

@James C4S

Setting the Board to Arduino Nano w/ Atmega 168 didn't work either.

This is probably my 2nd or 3rd time buying off Ebay and I thought I can trust a seller when they have >95% good reviews. Sigh.
I guess it's a $15 lesson for me. Already bought a genuine Uno R3 from an authorised distributor listed on the arduino webpage.

Thanks for the info and advice. When I have free time I guess I'll just refer to the official schematics and check the connections on the board.

Maybe they just 'forgot' to flash a suitable bootloader...

Just curious:
Why would anyone buy an Arduino (nano or other) off eBay when (a) there are plenty of reputable sellers listed on the Arduino website and (b) you are only saving a few bucks on eBay?

@madworm
I have an official Uno R3 now and I tried burning a bootloader to it, but it just doesn’t work. Can you shed some light on this? Thanks anyway.

@dlchambers
Nope its not just a few bucks. It’s half the price of an original Arduino. I’m from Malaysia and all of the official distributors in Malaysia are selling them for at least twice the price of the ones from Ebay. And the electronic supplies shops here do not carry Arduinos. When I ask them about Arduinos they go like ‘Huh?’. I can’t even get an Atmega chip here. So yeah. Anyway thanks for your input :slight_smile:

Hi everyone :slight_smile:
I've finally revived my Arduino Nano by checking the connections one by one referring to the official schematics. There was a tiny solder join that causes RESET to short to ground.
Please read it here for more info:
http://waihung.net/arduino-nano-revived-part-2/

Thank you for your inputs. This is a great community and I look forward to learn more here. Thanks again :slight_smile:

I got my arduino nano from the seller today and it works perfectly fine :slight_smile:

@vishalapr
You're luckier than me lol. Like I said in my website, the issue is with the bad soldering. The PCB and the components are fine though.
Glad it worked out for you :slight_smile:

Impressive work, man :slight_smile:

I will try and fix my arduino somehow...my previous one :slight_smile:

@remiss
Thanks :slight_smile:

@vishalapr
Try referring to the official schematics and check each connection. it will be tedious but it will take at most 2 hours.
well worth it instead of writing the arduino off.

Regarding your Nano, in your blog you posted, "... and there was once I mistakenly shorted 5V with Ground and the built-in fuse blew. I had to remove it and solder a jumper wire between the two pads."

That was not a fuse, that was a schottky diode.

Oh my bad. Thanks for heads up :slight_smile: