[Solved] Arduino Nano v3, stk500_getsync(): not in sync: resp=0x00

Greetings forum, I come to you today to try and discuss a problem I'm having. As you can probably tell by the subject, i can't upload sketches to my "Arduino compatible" Nano V3.0 board. running on Win7 Ultimate, x64, Arduino IDE 1.0.5-r2 what i've tried so far (with nothing connected on any pin), while trying to upload the "Blink" example: 1) things that failed -making triple sure the correct board and port are selected -pressing the reset button before upload begins (and before compiling) -long/multiple pressing of reset button before upload -plugging the board into different USB ports -uninstalling/reinstalling the FTDI drivers on each USB port -trying out all of the combinations of COM ports and board models 2) things that worked (kind of) -installed Arduino IDE 1.0.5-r2 and FTDI drivers on a friend's laptop with WinXP. worked instantly with the same board, so the chip isn't fired, and the bootloader is intact (on some forum i read that it's extremely rare but possible). I have been able to upload sketches to this exact board in the past from another computer without any problems.

I turned on the verbose output during Upload and I got this:

         Using Port                    : \\.\COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

What I'm able to gather from this output is that the baud rate is being changed from the default 9600 (for this board i think) to 57600 and thus communication could not be established. On the other hand it might mean that it's overriding the baud rate from 57600 to something else... I went into the Device manager and opened the settings for the COM port (in this case COM4) and under "Port settings" i can see that the Bits per second are set to 9600, data bits: 8, Parity:None, Stop bits:1, Flow control:None. So i guess my overall question is : should i mess around with the avrdude.conf file and try to sort out this override business by changing some values? As a side note: after the board is connected, when I hover the mouse cursor over the Tools menu, the LED on pin 13 blinks briefly, so there is some sort of communication between the PC and the board.

Any suggestions and/or opinions would be greatly appreciated,

Have a great day!

Just a heads up, I think I might have stumbled upon a possible solution, I'll try it out and report on the results in a couple of hours when i get off work.

Although my previous idea proved ineffective - to change the baud rate for the Nano in the boards.txt file from 57600 to 9600, i thought that perhaps 9600 was not the default baud rate for the Nano board with a 328P chip. After a quick google search for default baud rates on arduino boards, I yet again stumbled upon a possible solution to the problem. A user at another electronics forum had posted about the same problem i was having and in the replies someone suggested that he should: 1) uninstall the currently installed drivers that came with the arduino IDE (and stop windows from attempting to re-install them automatically). 2) download a different set of rivers from FTDI ( http://www.ftdichip.com/Drivers/CDM/CDM20824_Setup.exe ) and install them 3) restart windows if necessary

and it worked. (original forum/thread: http://electronics.stackexchange.com/questions/69224/arduino-nano-v3-atmega-328p-avrdude-stk500-getsync-not-in-sync-resp-0x00 , don't know if there are restrictions on posting links to other forums) too bad posting on that forum is tightly regulated, i would have liked to be able to thank the user more freely.

So if anyone is having this issue, try out the different set of drivers, I hope it helps.

Cheers!

In case this helps someone: The way I solved this was by setting the baud rate to 115200 in avrdude. It looks like, if the L LED is blinking for you, it's a baud problem. Just play around with the rates until you discover the right one.

Solved using ATmega328P (Old Bootloader)...

1 Like

dmeylman: Solved using ATmega328P (Old Bootloader)...

Aaaah, thanks!

1 Like

dmeylman:
Solved using ATmega328P (Old Bootloader)…

Thanks this solved the problem for me!

dmeylman: Solved using ATmega328P (Old Bootloader)...

What do you mean?

Same problem too.

The 2014 problem was actually a different cause with the same symptom. Search for “ftdigate” if you’re curious...

CATIOTOCAT:
What do you mean?

It’s an option in the IDE under tools->processor when you have the Nano selected. If you don’t have that option, upgrade the board manager to version 1.6.21 (1.6.22 and 1.6.23 seem to cause other problems at occasion).

CheLi2019: Same problem too.

Try the 328P option; if it does not work, try the 328P (old bootloader) option. If neither works, please report back with full details.

For full details, enable "show verbose output during upload" under file -> preferences in the IDE, copy the error messages and paste them here.

sterretje: Try the 328P option; if it does not work, try the 328P (old bootloader) option. If neither works, please report back with full details.

For full details, enable "show verbose output during upload" under file -> preferences in the IDE, copy the error messages and paste them here.

Arduino: 1.8.10 (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

Sketch uses 922 bytes (3%) of program storage space. Maximum is 30720 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes. C:\Users\dubba\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\dubba\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM9 -b57600 -D -Uflash:w:C:\Users\dubba\AppData\Local\Temp\arduino_build_454242/temp_control_box.ino.hex:i

avrdude: Version 6.3-20190619 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Users\dubba\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"

Using Port : COM9 Using Programmer : arduino Overriding Baud Rate : 57600 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xb7 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xb7

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

Getting same error with Nano; what worked is to look at the chip on the arduino web editor under "select other board and port" and change to ATMega 328P Old bootloader!