[solved] Arduino Pro IDE Issue: Cmd-R shortcut globally disabled while app open

Hello,

Thank you for reading this. I firstly have to add that I've already submitted a bug report for this issue, and am posting here to see if anyone has found a temporary workaround.

The Bug
While Arduino Pro IDE is open, Cmd-R ("refreshing" shortcut) does not work in any relevant application (Safari, Chrome, Firefox, etc.).

Reproduction
Steps to reproduce the behavior:

  • Launch 'Arduino Pro IDE'
  • Launch 'Safari' or 'Chrome'
  • Try to refresh a page using Cmd-R in either 'Safari' or 'Chrome'
  • Encounter the issue

Expected behavior
While manual clicking on the "refresh" button in either relevant application refreshes the page, Cmd-R does not do its intended action.

Desktop
OS: OS X
Version 10.15.5

For reference (since there is likely to be an official response there at some point), ArianKS's bug report:

Are you really posting about an alpha preview of an IDE that hasn't been completed? What do you want to know from the community?

Perehama:
Are you really posting about an alpha preview of an IDE that hasn't been completed? What do you want to know from the community?

Thanks for the reply. Like I mentioned in the post, I was wondering if someone's found a workaround about this issue.

ArianKS:
Thanks for the reply. Like I mentioned in the post, I was wondering if someone's found a workaround about this issue.

Apple "Settings>Keyboard>Shortcuts. Select "App Shortcuts". Click "+". Select Chrome. Then change the shortcut behavior for refresh.

Perehama:
Apple "Settings>Keyboard>Shortcuts. Select "App Shortcuts". Click "+". Select Chrome. Then change the shortcut behavior for refresh.

Thank you for the suggestion—the issue is that I have to do that for every single app I use that has Cmd-R as a useful shortcut. Worse comes to worst I'll do that.