[solved] Arduino to 4051 demux to optocoupler to HomeEasy remote problem

Hi all,

I'm trying to control a HomeEasy remote with the Arduino. I followed the instructions on this page http://www.instructables.com/id/Arduino-Home-automation/step2/Basic-principle/

(Arduino pin --> optocoupler --> remote switch)

However instead of using 8 cables for the 4 on/off remote switches I used a 4051 demux so that I can save some pins on the arduino. I also did not use any LEDs.

If I go from an Arduino pin directly to the optocoupler and send a signal, the remote switches as it should.

If I measure resistance on the optocoupler on the side of the HomeEasy remote... and send something through the demux... I can see that the optocoupler is indeed switched...so the circuit is ok I guess... but the remote does not react at all... :(

Could this be a problem with too much resistance? What can I do to fix this? Sorry I'm a beginner on circuits.

The optocouplers I am using http://uk.farnell.com/vishay-semiconductor/ild1/optocoupler-transistor-o-p/dp/1469477

The demuxer I am using http://at.farnell.com/nxp/hef4051bp/single-8-chan-mux-4051/dp/385347?Ntt=385347

Thanks for your help

--- update

schematics http://img593.imageshack.us/i/schematic.gif/

--- another update

Heureka! I found it. Turned out that when I had all outputs of the 4051 connected, I was sending always, even when LOW, LOW, LOW as input. But the remote didn't seem to like that and couldn't switch. When I unplugged the wire going from Y0 --> switch 1 OFF it worked! That means currently I cannot turn off switch 1... but at the moment I only have 3 things to control anyway and I could extend the circuit :)

The optocouplers I am using ........ The demuxer I am using .......

The schematic you are using?

Without seeing this it is hard to say.

What I can say is the 4051 is the wrong chip for output multiplexing because:- 1) It is analogue 2) It has no output latch so any signal is only momentary.

If I go from an Arduino pin directly to the optocoupler and send a signal, the remote switches as it should.

You are using a current-limiting resistor between the Arduino pin and the opto-coupler input I hope... And yes without the circuit its impossible to know what's going on.