[SOLVED]Arduino15 folder is missing

The title says it all.

C:\Users\YourUsername\Documents\ArduinoData does not exist(for I first tried Windows store version)

and I installed the regular version, but C:\Users\YourUsername\AppData\Local\Arduino15 neither exists.

Can there be another directory where my Arduino15 folder hides, or can I just download the folder manually from somewhere else?

I use Windows10
Thank you in advance for any help.


Edited after the resolution

The actual problem I had here was that the IDE wasn't starting after the first installation.

The first solution I found from GitHub was to find your Arduino15 and delete the blah_blah.json, but that wasn't my Issue for I wasn't able to start the IDE for the first time and the Arduino15 folder creates after the first run. So, In my case, I was finding something that was just not being created.

So I looked around a bit and tried running the arduino_debug.exe, but it came up with a "Could not reserve enough space" error.

so I modified my arduino.l4j.ini and arduino_debug.l4j.ini(for those who find where these are, they are right below arduino.exe and arduino_debug.exe respectively ) to -Xmx768M to fit in my _JAVA_OPTIONS' max heap, which was -Xmx1024M.

after that, I saved my changed .ini files, Closed and Restarted the terminal (believe or not, I re-tried at least trice without restarting my terminal, and it just didn't work.)
and reran the arduino_debug.exe.

the debug.exe fixed the issue, and now the IDE works just fine.

@uqbar2718 It could be that the Arduino15 directory is hidden on Windows Explorer.

Have you tried clicking on the Explorer's View tab and selecting the File Names Extensions and Hidden Items check boxes?

@pert

I'm not sure, but this folder MAY not be created until a sketch is compiled, or a library/board is installed frm their managers!

1 Like

Yes, and that didn't help. :frowning:

Have you tried typing it in in file explorer?

Which version of the IDE are you using?

this was the reason, and actually, it was a bit more fundamental. But long story short, I had to change arduino.l4j.ini and arduino_debug.l4j.ini 's Xms to fit the max heap size, and after running the arduino_debug.exe, It fixed my IDE and after running Arduino IDE once, I got my Arduino15 folder in the right spot!