[SOLVED] ATmega8 - troubles

Arduino UNO R3 as ISP, Arduino 1.6.7 IDE
"Arduino NG or older" as breadboard.

BURNING BOOTLOADER:

avrdude adds
-Uefuse:w:{bootloader.extended_fuses}:m
to programming command and got message
"efuse" memory type not defined for part "ATmega8
at the end.

Those fuses exists in ATmega328 chips.

UPLOAD SKETCH:
ends with
avrdude: Device signature = 0x1e950f
avrdude: Expected signature for ATmega8 is 1E 93 07
** Double check chip, or use -F to override this check.**

Looks like signature was get from "Arduino as ISP" board.

It's question of config arduino IDE or avrdude?

SOLUTION:
Get power from externall source - not only from USB!

Board "Arduino NG or older" - upload bootloader via terminal avrdude - not in Arduino IDE.
Sketch - upload via terminal avrdude with -F option.

OR :slight_smile:

Board "Arduino/Genuino Uno" - upload bootloader (for ATmega8) via terminal avrdude - not in Arduino IDE.
Sketch - upload via Arduino IDE.

How to omit adding -Uefuse:w:{bootloader.extended_fuses}:m by Arduino?

this is a bug in the arduino ide and has been for a long time. simplest fix is to delete reference to efuse in platform.txt file. fancy fix is to create a new core with proper settings.

this make couple dozen times recently similar issue cropped up. a sticky with common problems including many dealing with popular usbasp and other repeated posts would help. over and over same cries for assistance. hundreds of thousands if not millions of man hours wasted chasing tails. its unfortunate those who run the forum consider things like adc benchmarks more important.