***SOLVED*** Atmel-based Arduinos and the Mac: Serial Ports not displaying

As a relative newcomer to the Arduino, I've been struggling for days without success trying to get a new Arduino Uno R3 board working on my Mac. I'm reposting in hopes someone can assist. I can't help but think of all of the wonderfully creative people (including 4 of 8 people at a recent Intro to Arduino course I took) who want to build interesting projects ranging from sound analyzers to interactive art installations...who all have a Mac.

My background: I've been using PCs of some sort since 1979 and I've made my living in the tech industry for 32 years. Not a lot of dense programming experience, but I've been around my fair share of systems configuration work since Day 1.

If I can't figure this out, there is a problem with the ecosystem in which Arduino is purporting to operate. More than a new IDE, someone should set their sights on solving what appears to be a chronic problem.

Here's what I've done or learned:

  1. The Arduino Uno R3 and some clone versions of the Nano run Atmel 16U communications chips that do not require a discrete software-based driver, but rather have a firmware-based driver. You will therefore not find a driver for the Mac for the Atmel chipset. You should also ignore all advice related to FTDI drivers, as this is not an FTDI-based chipset.

  2. I have installed both Java 6 SE (Apple's distribution) from here.

  3. I have verified the Java 6 SE install via > java -version from the terminal command line. I get this result:

java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

I did note that it is running in 64-bit mode. I've looked for ways to force 32-bit mode to try that, but no avail. Not sure if that would matter anyway.

  1. I have run Arduino's IDE 1.06. The serial ports do not appear. I only get Bluetooth enumerated (see the kajillion posts on this issue anywhere else in this forum for similar experiences). Note: "kajillion" may be a slight exaggeration. I am also not sure if that is a real number. It may be closer to quattuordecillion.

  2. I have installed Java 8, latest build from Oracle's site. I have verified its install via Oracle's verifier.

  3. I have run the Java 7 (which actually should read, "Java 7 or greater") 1.5.x and 1.6 builds of the Arduino IDE. The serial ports do not appear (see #3 comments above).

  4. I have alternately done 2 through 5 uninstalling and reinstalling in various combinations. No luck.

  5. I have run the Apple System Information tool and when I plug the Uno R3 or (either of two that I have) Nano clone boards in, no change to the USB Device Tree can be seen. This worries me. It suggests to me that the Mac doesn't know that a USB device has been attached.

  6. I have tried this on two different Macs: a MacBook Pro (2010) and a MacBook Air (2014). Both running Yosemite build 10.10.1 and now 10.10.2 since the new update over the weekend.

  7. I have read forums here on arduino.cc as well as the Sparkfun boards (just in case someone there has solved the problem.

I'm really truly wanting to get on with developing some neat projects with my Arduino gear. No, I don't want to buy a PC to just bail on the problem. I've got a Windows laptop that I could use, but I refuse to contribute to a problem by avoiding it.

I'd like to solve the problem and post the full solution. Who can help?

Many thanks!

d.

Update: I can get a Nano clone w/Atmel 16U to show up as USB2.0-Serial ports in the System Information utility of the Mac. Still does not show in the Arduino software.

It shows up in the System Information utility as:

USB Hi-Speed Bus

Hub

Apple Internal Keyboard / Trackpad

BRCM2070 Hub

Bluetooth USB Host Controller
USB2.0-Serial
Internal Memory Card Reader

USB Hi-Speed Bus

Hub
USB2.0-Serial
IR Receiver
Built-in iSight

OK. I just got my Uno R3 (authentic Arduino out of box) working. Here's what went down:

I'm running 10.10.2 Yosemite. Java 1.8.0_31-b13 (aka Java 8). Arduino IDE 1.6.

First, ignore all that FTDI driver stuff. The Uno R3 (Arduino branded) does not use this chipset. There are NO drivers required to get this board working. It loads drivers from firmware when you connect it.

Next, if you check your version of Java in Terminal, it won't respond to > Java -version. It will just keep prompting you to install Java unless you have an old version of Java (like Java SE 6) installed. If you want to know if it's installed correctly, a tip-off is that you should see a Java icon in your System Preferences pane.

What mystified me is I bought two Uno R3 boards, and two USB 2.0 A to B cables. I have two Macbook Pros and one Macbook Air in the house and an HP laptop. Nothing worked. Not even recognized by the OSes, let alone the Arduino IDE.

I wanted this to work on the Mac because my son and I are both experimenting with the boards. Finally (as I mentioned above), I broke down and used my HP laptop from work to try and get it working. Nothing.

So I went and bought a different USB cable from a different place.

It worked. It shows up as USB Modem - Not Configured in the Network pane under System Preferences. It shows up as /dev/cu.usbmodemfd131 (Arduino Uno) under the Arduino IDE Tools>>Port menu.

I suspect some USB cables are sh*t (I'm shocked!). I'm not sure if the hardware is just sensitive or whether someone managed to botch a simple USB cable run, but this was my experience. I hope this helps you.

d.

I’m having the same problem, but I don’t think it’s a cable matter, I’ve tried 7 (SEVEN) different cables, all of them working properly with others devices, and no one worked. I simple don’t work. If anyone knows a different solution, please tell me.
Thank you.