[SOLVED] AVRDude Not supporting Mega2560 (Eclipse Arduino Plugin)

Hi All,

I’ve been unable to find a solution to a problem no one else seems to have had.
I’m trying to get the Eclipse Arduino Plugin to function; all is well until upload time.
I’ve followed the easy install instructions on This page has been moved and the project creation http://www.baeyens.it/eclipse/UsethePlugin.html .

Problem is, when i go to use the AVR button to upload to my Mega2560 R3, i get the following error: (also shown in the picture attached)

“AVRDude does not support the project target MCU [Atmega2560]
Please select a different target MCU and try again if you want to use AVRDude”

Has anyone got any ideas on how to help me with this; it would be greatly appreciated. Also it will be up here for anyone else with the issue.

Thanks in advance.

AVR Dude Error.PNG

i was having this problem but cant remember how i get out of this if i remember correct u can re-install this plugin and the problem will go away or if not u can simply change the MCU val MCU is the clock of u board if im not mistaken

I’m using the Mega 2560 in half of my projects. So this works :D.
Can you dump the console output? and provide the version you are using of the plugin?
Best regards

Thanks both of you for the replies. I’ve had this same problem using eclipse Kepler and Juno; currently i’m trying juno with the following

The Arduino Eclipse Plugin is Version
The Eclipse IDE is

I’m using 32bit Juno on a Win7x64 machine.

The arduino IDE does sucessfully program the board.

The console output from eclipse when building the project is quoted below. (with verbose)

11:19:25 **** Build of configuration Release for project MySketch ****
make all
Building file: …/MySketch.cpp
Invoking: AVR C++ Compiler
avr-g++ -I"D:\Programs\arduino-1.0.5\hardware\arduino\cores\arduino" -I"D:\Programs\arduino-1.0.5\hardware\arduino\variants\mega" -I"D:\Workspace_Arduino\MySketch" -D__IN_ECLIPSE__=1 -DUSB_VID= -DUSB_PID= -DARDUINO=105 -Wall -Os -ffunction-sections -fdata-sections -fno-exceptions -v -g -mmcu=atmega2560 -DF_CPU=16000000UL -MMD -MP -MF"MySketch.d" -MT"MySketch.d" -c -o “MySketch.o” -x c++ “…/MySketch.cpp”
Using built-in specs.
Target: avr
Configured with: …/gcc-4.3.2/configure --enable-win32-registry=WinAVR-20081205 --with-gmp=/usr/local --with-mpfr=/usr/local --prefix=/c/WinAVR --target=avr --enable-languages=c,c++,objc --with-dwarf2 --enable-doc --disable-shared --disable-libada --disable-libssp --disable-nls --with-pkgversion=‘WinAVR 20081205’ --with-bugurl=‘URL:http://sourceforge.net/tracker/?atid=520074&group_id=68108&func=browse
Thread model: single
gcc version 4.3.2 (WinAVR 20081205)
COLLECT_GCC_OPTIONS=’-ID:\Programs\arduino-1.0.5\hardware\arduino\cores\arduino’ ‘-ID:\Programs\arduino-1.0.5\hardware\arduino\variants\mega’ ‘-ID:\Workspace_Arduino\MySketch’ ‘-D__IN_ECLIPSE__=1’ ‘-DUSB_VID=’ ‘-DUSB_PID=’ ‘-DARDUINO=105’ ‘-Wall’ ‘-Os’ ‘-ffunction-sections’ ‘-fdata-sections’ ‘-fno-exceptions’ ‘-v’ ‘-g’ ‘-mmcu=atmega2560’ ‘-DF_CPU=16000000UL’ ‘-MMD’ ‘-MP’ ‘-MFMySketch.d’ ‘-MTMySketch.d’ ‘-c’ ‘-o’ ‘MySketch.o’
d:/programs/arduino-1.0.5/hardware/tools/avr/bin/…/libexec/gcc/avr/4.3.2/cc1plus.exe -quiet -v -ID:\Programs\arduino-1.0.5\hardware\arduino\cores\arduino -ID:\Programs\arduino-1.0.5\hardware\arduino\variants\mega -ID:\Workspace_Arduino\MySketch -imultilib avr6 -iprefix d:\programs\arduino-1.0.5\hardware\tools\avr\bin…/lib/gcc/avr/4.3.2/ -MMD MySketch.d -MFMySketch.d -MP -MTMySketch.d -MQ MySketch.o -D__IN_ECLIPSE__=1 -DUSB_VID= -DUSB_PID= -DARDUINO=105 -DF_CPU=16000000UL …/MySketch.cpp -quiet -dumpbase MySketch.cpp -mmcu=atmega2560 -auxbase-strip MySketch.o -g -Os -Wall -version -ffunction-sections -fdata-sections -fno-exceptions -fno-rtti -fno-enforce-eh-specs -fno-exceptions -o C:\Users\agibson\AppData\Local\Temp/ccJNh9mT.s
ignoring nonexistent directory “d:/programs/arduino-1.0.5/hardware/tools/avr/lib/gcc/…/…/avr/include/c++/4.3.2”
ignoring nonexistent directory “d:/programs/arduino-1.0.5/hardware/tools/avr/lib/gcc/…/…/avr/include/c++/4.3.2/avr/avr6”
ignoring nonexistent directory “d:/programs/arduino-1.0.5/hardware/tools/avr/lib/gcc/…/…/avr/include/c++/4.3.2/backward”
ignoring nonexistent directory “d:/programs/arduino-1.0.5/hardware/tools/avr/lib/gcc/…/…/avr/sys-include”
#include “…” search starts here:
#include <…> search starts here:
End of search list.
GNU C++ (WinAVR 20081205) version 4.3.2 (avr)
compiled by GNU C version 3.4.5 (mingw-vista special r3), GMP version 4.2.3, MPFR version 2.3.2.
GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: a5eaa4751655043614dbbfd845ac39f8
COLLECT_GCC_OPTIONS=’-ID:\Programs\arduino-1.0.5\hardware\arduino\cores\arduino’ ‘-ID:\Programs\arduino-1.0.5\hardware\arduino\variants\mega’ ‘-ID:\Workspace_Arduino\MySketch’ ‘-D__IN_ECLIPSE__=1’ ‘-DUSB_VID=’ ‘-DUSB_PID=’ ‘-DARDUINO=105’ ‘-Wall’ ‘-Os’ ‘-ffunction-sections’ ‘-fdata-sections’ ‘-fno-exceptions’ ‘-v’ ‘-g’ ‘-mmcu=atmega2560’ ‘-DF_CPU=16000000UL’ ‘-MMD’ ‘-MP’ ‘-MFMySketch.d’ ‘-MTMySketch.d’ ‘-c’ ‘-o’ ‘MySketch.o’
d:/programs/arduino-1.0.5/hardware/tools/avr/bin/…/lib/gcc/avr/4.3.2/…/…/…/…/avr/bin/as.exe -mmcu=atmega2560 -o MySketch.o C:\Users\agibson\AppData\Local\Temp/ccJNh9mT.s
Finished building: …/MySketch.cpp

Building target: MySketch.elf
Invoking: AVR C++ Linker
COLLECT_GCC_OPTIONS=’-ID:\Programs\arduino-1.0.5\hardware\arduino\cores\arduino’ ‘-ID:\Programs\arduino-1.0.5\hardware\arduino\variants\mega’ ‘-ID:\Workspace_Arduino\MySketch’ ‘-D__IN_ECLIPSE__=1’ ‘-DUSB_VID=’ ‘-DUSB_PID=’ ‘-DARDUINO=105’ ‘-Wall’ ‘-Os’ ‘-ffunction-sections’ ‘-fdata-sections’ ‘-fno-exceptions’ ‘-v’ ‘-g’ ‘-mmcu=atmega2560’ ‘-DF_CPU=16000000UL’ ‘-MMD’ ‘-MP’ ‘-MFMySketch.d’ ‘-MTMySketch.d’ ‘-c’ ‘-o’ ‘MySketch.o’
avr-gcc -Os -Wl,–gc-sections -L"D:\Workspace_Arduino\Arduino_Mega_2560_or_Mega_ADK/Release" -mmcu=atmega2560 -o"MySketch.elf" ./MySketch.o -l"Arduino_Mega_2560_or_Mega_ADK" -lm
Finished building target: MySketch.elf

Invoking: AVR Create Extended Listing
avr-objdump -h -S MySketch.elf >“MySketch.lss”
Finished building: MySketch.lss

Create Flash image (ihex format)
avr-objcopy -R .eeprom -O ihex MySketch.elf “MySketch.hex”
Finished building: MySketch.hex

Create eeprom image (ihex format)
avr-objcopy -j .eeprom --no-change-warnings --change-section-lma .eeprom=0 -O ihex MySketch.elf “MySketch.eep”
Finished building: MySketch.eep

Invoking: Print Size
avr-size --format=avr --mcu=atmega2560 MySketch.elf
AVR Memory Usage

Device: atmega2560

Program: 1660 bytes (0.6% Full)
(.text + .data + .bootloader)

Data: 11 bytes (0.1% Full)
(.data + .bss + .noinit)

Finished building: sizedummy

11:19:26 Build Finished (took 1s.29ms)

I meant the console output from the upload.

Upon clicking the AVR button, the error pop up is immediate and there is not console print what so ever.. which is odd i suppose. I use the console window option to see both the CDT global and CDT build console prints and they are blank.

Just got a hold of a UNO. It does the same thing....... Something is wrong obviously. I found an option to output AVR dude to the console and when trying to to do the UNO, the console prints

Launching D:\Programs\arduino-1.0.5\hardware\tools\avr\bin\avrdude -p? Output: avrdude: can't open config file "": Invalid argument avrdude: error reading system wide configuration file "" avrdude execution aborted

Got it, from looking at that console output; i noticed that the AVR Dude setttings under Preferences/Arduino/AVR were not set.

So i manually set them to whats shown in the image. I pointed to an avrdude.conf i found by using windows search.

My understanding of the Arduino instructions and FAQ gave me the impression that clicking “Use Arduino IDE Tools in eclipse” did this sort of thing… was i wrong or a bug in the plugin?

NOTE i’d also rolled back to the Arduino plugin 1.2.4 though this isn;t the reason i fixed it.

Thank you both Jantje and THX_RoG for taking the time to help me out.

“Use Arduino IDE Tools in eclipse” should set those. If it didn’t this is a bug.

if there is any other info you need, just let me know.

If you have steps to reproduce :-)

I found that when setting up the plug in that if I set all the preferences in one go then it wouldn't work. But if I set the paths only, then applied changes, then exited preferences, then reopened preferences and St The use arduino ide setting... It would then work. Also note all my earlier attempts and these ones were all done on fresh Eclipse installs. Also your plug in works on kepler eclipse.

Thabk you for making such a plugin.

In Version V1 there is indeed inconsistency's when changing preference settings. These are fixed in V2 beta (Arduino IDE 1.5.2 beta only) Best regards Jantje

Could someone familiar with using AVRDude from Eclipse please post the details from their programmer specifications page for the Mega2560? I am not using the plugin, but I do have Eclipse working for the Uno...I just cannot seem to get it to upload for the Mega. I got the settings from the boards.txt file, but even with those the upload fails. There is indeed an error window that pops up for about 100ms, but it's gone way too fast to get any idea what the issue is. Then when I try to go back into the project's preferences to edit the programmer preferences, I get a message to the effect of

The currently displayed page contains invalid values.

This generally appears when I select the AVR > AVRDude menu option there in the lefthand page. However there's really no indication as to which values(s) is(are) invalid...

So if someone could share the settings they've gotten to work with AVRDude and the Mega2560, I would greatly appreciate it.

Thanks in advance.