[Solved]avrdude: stk500_recv(): programmer is not responding on OSX Maverick

I was working with Arduino UNO R3, and everything works fine for me, but after a couple of experimenting, I've done a really bad mistake of shorting the GND and VCC. Since then , my mac seems to be unable to program any Arduino UNO, I know this, since:

  • I've tried to program the same Arduino on my friends laptop and it works just fine
  • I've tried another arduino which is fine on other laptop on my mac as well, and I still face this problem
  • I've tried the reset button trick, and yet still I don't see any differences

could anyone help? I'm really looking forward to further experimenting with Arduino on my mac please

I am having the same problem on the MAC OS here is the verbose and it looks like an arduino file is missing. Can't find it on the net. Maybe one of the Guru's can help.

avrdude: Version 5.11, compiled on Sep 2 2011 at 18:52:52 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf" User configuration file is "/Users/WebDev/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/tty.usbmodemfd131 Using Programmer : arduino Overriding Baud Rate : 115200 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: ser_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

avrdude done. Thank you.

Anyway, after a relatively long wait for answer, I realise I haven’t tried everything yet, so…
I tried doing these:

  • Redownloading Arduino software (the 1.0.5 version, since I used the 1.5.x version earlier)
  • Installing newest FTDI driver for OSX
  • try to mingle with the serial port (I changed it to USBmodem one)

And after those, I tried to upload my program, and it works, yet, I don’t know which one(s) solve my problem, I hope it helps