[SOLVED] Bluetooth Mate Silver Not Communicating in Command Mode

Hey! I’m working with a newly purchased Bluesmirf Silver (with the RN42 chip) and have read all the documentation. I have wired it according to the tutorial (Using the BlueSMiRF - learn.sparkfun.com). The BT chip is connected to 5V, with its Rx to my Mega 2560’s Tx and vice versa.

I paired it with my pc perfectly fine, and and using Termite (set to 115200 baud 8-N-1 as per instruction) I am able to send the “$$$” command to enter command mode, and get “CMD” sent back to me. So far so good. HOWEVER, after this point, nothing I type gets a reply.

I used the Bluetooth Terminal app on my Android device, and was able to enter command mode there as well. The blinking red LED changed to the 10blinks/sec as it should, and I get the CMD reply. Once again, anything after this point is ignored.

Commands tried (without quotations):
“e” and “E”
“d” and “D”
“U, 9600, N”
“—”

It may be worth noting that after the 60sec delay after power up, the stat LED keeps flashing at the 2/sec rate instead of reverting to the 1/sec to show it is no longer able to enter command mode.

I have tried:
*Turning off all nearby bluetooth devices
*Powering arduino from an external power supply while using Terminal over bluetooth
*Using a sketch to input the commands (sketch from link above)
*Appending CR or LF (If i do either or both of those, it will not enter command mode)
*All the flow control options

Any help would be GREATLY appreciated

EDIT:
Sketch shown below

/*
  Example Bluetooth Serial Passthrough Sketch
 by: Jim Lindblom
 SparkFun Electronics
 date: February 26, 2013
 license: Public domain

 This example sketch converts an RN-42 bluetooth module to
 communicate at 9600 bps (from 115200), and passes any serial
 data between Serial Monitor and bluetooth module.
 */
#include <SoftwareSerial.h>  

int bluetoothTx = 2;  // TX-O pin of bluetooth mate, Arduino D2
int bluetoothRx = 3;  // RX-I pin of bluetooth mate, Arduino D3

SoftwareSerial bluetooth(bluetoothTx, bluetoothRx);

void setup()
{
  Serial.begin(9600);  // Begin the serial monitor at 9600bps
/*
  bluetooth.begin(115200);  // The Bluetooth Mate defaults to 115200bps
  bluetooth.print("$");  // Print three times individually
  bluetooth.print("$");
  bluetooth.print("$");  // Enter command mode
  delay(100);  // Short delay, wait for the Mate to send back CMD
  bluetooth.println("U,9600,N");  // Temporarily Change the baudrate to 9600, no parity
  // 115200 can be too fast at times for NewSoftSerial to relay the data reliably
  */
  bluetooth.begin(9600);  // Start bluetooth serial at 9600
}

void loop()
{
  if(bluetooth.available())  // If the bluetooth sent any characters
  {
    // Send any characters the bluetooth prints to the serial monitor
    Serial.print((char)bluetooth.read());  
  }
  if(Serial.available())  // If stuff was typed in the serial monitor
  {
    // Send any characters the Serial monitor prints to the bluetooth
    bluetooth.print((char)Serial.read());
  }
  // and loop forever and ever!
}

Got a new chip, and the same issue persists. Please, I need help with this as I cannot see anything I'm doing wrong. I literally took it out the packet, soldered the header pins on, connected to 5V and paired with computer. Same issue, after it sends back CMD nothing changes.

Please help

Figured it out, felt like a chop.

After sending the command $$$ without appending the newline suffix, I had to swap to using it (ACSII code 13). Termite breaks the connection and restarts it every time you change this setting, but I used the Arduino serial monitor and it worked like a charm (Yes, I know I can use TeraTerm and putty and so on, but Arduino was open).

Also, I went into Device Manager, opened up the Serial Port I was using, and in the properties set the baud rate there to 115200 as well.

At long damn last