Hi, I am almost new to Arduino, although in the last weeks I did more or less what I wanted with it, until yesterday. I have a MKR WAN 1300, and I use the IDE on a Mac (High Sierra). After having attempted to load the LMIC library instead of the original, the serial port disappeared (I suspect due to a conflict in pins configured on LMIC, which likely is not supposed to run on a MKR. Don't ask me why I tried). I tried almost all the workarounds for missing serial ports on a Mac, with no success (change port, cable, reboot, reset PRAM). I tried the loopback test but since there is no serial, I could not do it really.

However, when powered, the Arduino remains with both leds on (green and yellow). Is this the case where I have to reload the bootloader with ArduinoISP?

Thanks for your help.

Ok, some update: I decided to reinstall the bootloader using another MKR (1000). This one is recognised by the IDE, so serial is available, I tested it with usual blink sketch, and then uploaded the ArduinoISP sketch. However, carefully following the steps described here, when I choose "Burn bootloader", an error appears:

"Please select a programmer from Tools->Programmer menu". Arduino as ISP is of course selected in the programmer menu.

I also installed the 3 leds managed by the sketch (however, on different pins because the ones suggested are in part used by MISO MOSI SCK). The 3 blink sequence in the setup is ok, the heartbeat is present.

So, I am still in need of help. Or tell me that there is nothing to do, and I will let it in the drawer :)

I finally found here a workaround: quickly double tapping the reset button. The serial port reappeared, and I was able to upload a sketch. Happy now.

Thanks. You just saved me a lot of grievances. :-)

The arduinoIsp sketch will only allow you to put bootloaders on AVR chips, not the Sam chips used on the MKR boards.

Thanks MITEL I had just hit the reset but not a double click. I think I have know that before but it just one of those things that doesn't happen that often.