[SOLVED]Broken (?) Arduino Uno

I've got a slight problem with my Arduino Uno. Someone borrowed my Arduino for a day, and guess what... It didn't work any more when he returned it :0

The arduino basicly does nothing. It powers on (led turns on), and the led on digital pin 13 flashes a couple of times, and that's all. There's no visible damage (as far as I'm concerned). The computer also doesn't recognize it. Not even as an unknown device. Literally nothing. Which made me think that it might be a bootloader problem. So I tried flashing the bootloader through another arduino. I used the following tutorial: http://arduino.cc/en/Tutorial/ArduinoISP

But it didn't help. So I figured I'd ask the pro's :D. Any idea what might be a problem, or even better, how to fix it?

If the Arduino doesn't show up as a USB device then the problem is likely in the USB-to-Serial part of the Arduino UNO. This is a separate processor with separate firmware. Here are the instructions for re-flashing the USB-to-Serial firmware:

http://arduino.cc/en/Hacking/DFUProgramming8U2

Thanks mate! I did know there was an additional processor, but I didn't think the problem laid there. Anyhow I tried it and it worked! My arduino is back alive!