SOLVED: BUG In Nano Mbed 2.0.0 ; NANO 33 BLE Issue with Adafruit Neopixel Library On Web Editor?

Hello All,

I’ve encountered a snag with (I think) the Adafruit Neopixel library on the Create Web Editor. I’ve been able to verify and upload this code to the board many times until this week.

Board: Arduino Nano 33 BLE
OS: Mac Mojave
Browser: Chrome

Things I’ve tried to no avail:
-Including previous versions of the library
-Reloading the Web Editor
-Desktop IDE, but have issues with compiling for 33BLE (I know what people recommend on the forum, doesn’t work)

Project Description:
Small robot with “behavioral” state changes sensed via Lidar Sensor and BLE RSSI. Activates a neopixel ring and different states of movement with two micro servos. This is a grad school project.

Here is the link to my sketch on the web editor: Arduino Create

And here is a copy/paste of the error I’m getting when I try to compile, shortened a bit for readability with a screen shot at the bottom. It describes an error:

(. . . )
Not used: /home/builder/opt/libraries/latest/servoesp32_1_0_3
Not used: /home/builder/opt/libraries/latest/rokitsmart_1_0_9
Not used: /home/builder/opt/libraries/latest/printoo_library_1_0_2
Not used: /home/builder/opt/libraries/latest/evive_2_0_3

Using library Wire in folder: /home/builder/.arduino15/packages/arduino/hardware/mbed/2.0.0/libraries/Wire (legacy)

Using library vl53l1x_1_3_0 at version 1.3.0 in folder: /home/builder/opt/libraries/latest/vl53l1x_1_3_0

/home/builder/opt/libraries/latest/adafruit_neopixel_1_8_0/Adafruit_NeoPixel.cpp: In member function ‘void Adafruit_NeoPixel::show()’:

/home/builder/opt/libraries/latest/adafruit_neopixel_1_8_0/Adafruit_NeoPixel.cpp:1528:45: error: invalid use of incomplete type ‘PinDescription {aka struct _PinDescription}’

pwm->PSEL.OUT[0] = g_APinDescription[pin].name;

^

In file included from /home/builder/opt/libraries/latest/adafruit_neopixel_1_8_0/Adafruit_NeoPixel.h:41:0,

from /home/builder/opt/libraries/latest/adafruit_neopixel_1_8_0/Adafruit_NeoPixel.cpp:46:

/home/builder/.arduino15/packages/arduino/hardware/mbed/2.0.0/cores/arduino/Arduino.h:83:16: note: forward declaration of ‘PinDescription {aka struct _PinDescription}’

typedef struct _PinDescription PinDescription;

^~~~~~~~~~~~~~~

exit status 1

Thanks for your help in advance.

Stop using the web editor?

-jim lee

@jimLee Useless response. I found the issue, in case you’re curious.

It’s with the new boards package for the Nano mbed boards. Went back to the IDE, deleted the programs file and reinstalled the previous version of Arduino Mbed OS Boards (1.3.1). Everything works again.

2.0.0 needs a fix. And not being able to choose which version of Arduino Mbed OS Boards is being used in the Web Editor is something people need to watch out for.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.