[SOLVED] Burning Bootloader to Sanguino ATmega1284P

Hi,

i have a creality 3D Printer mainboard here and i wanted to burn the bootloader.
OS is Linuxmint 19.3

What i have done so far:

  • Set up an arduino uno as ISP
  • Added Sanguino as Boards in Arduino IDE 1.8.13
  • Wired everthing up and selected Board: Sanguino, CPU: ATmega1284P (16MHz)
  • Port: The Arduino Uno Port

When clicking on Burn Bootloader it brings up this error:

Arduino: 1.8.13 (Linux), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Exception in thread "MessageSiphon" java.lang.NoSuchMethodError: org.apache.commons.lang3.StringUtils.containsAny(Ljava/lang/CharSequence;[Ljava/lang/CharSequence;)Z
at cc.arduino.packages.Uploader.message(Uploader.java:158)
at processing.app.debug.MessageSiphon.run(MessageSiphon.java:96)
at java.lang.Thread.run(Thread.java:748)
Fehler beim Brennen des Bootloaders.

Did that for my Ender3 Pro creality board some time ago. That was on Windows10 however.

Used MightyCore, set for 1284P, 16MHz external, LTO Enabled, Sanguino pinout and Bootloader Yes(UART0). Worked no problem. Been updating Marlin till everything I needed worked and then stopped (that was a while ago).

Hope you get it sorted.

Willem.

Found the issue, i somehow messed up my Arduino installation directory. Downloaded it again and the java error was gone. Additionally i had to put a capacitor between RESET and GND on the arduino uno (the programmer) to fix a protocol error.

Glad to hear you sorted it.

Yes the cap is required on the UNO.

Willem.