[Solved] Cancelling compiling without any error

Hi,

I was trying to compile my Arduino Marlin Firmware via Web-Create. At a point, it stops, showing no log and tells me, to communicate this error to the forum. But there is no entry, to find, where the error takes place. Also within the compilation process, there is no output within the console.

I'm using Google Chrome (56.0.2924.87) on Windows 10 pro (64Bit).

What can I do?

Friendly

Burkhard Kneiseler

Same problem here, its very annoying. Verify and Saving is working fine, but every 2 or 3 hours the Upload and Save wont work. The only Message is:Compilation failed. Please report this issue on our forum. Verbose output is empty.

My only solution: Copy Code into a new sketch, it will work for a short time...

My System:
Win10 X64, Firefox

Not 100% sure the online is quite ready for 3d "FIRMWARE" maybe better you try the regular IDE ?

I think this is due to the expiration of the authentication token. It will be solved as soon as possible. Sorry about that

The authentication token issue has been solved, please let us know if you still experience this problem. Thank you for your patience.

Hey,

thanks for the replys.

Unfortunately I still have the same problem actually. But now I need to sign out the webeditor, Log In, create a new sketch, copy and cast the code to get it working for a short time.

The webeditor also have a strange behavior when this problem occurs:

  • Verify and Save Button: No Warning, it seems everything is fine.
    "Success: Saved on Arduino CLoud and done Verifying..."

But the Sketch was not saved. If I LogOut and LogIn the changes which i made were not saved

  • Can´t Download the sketch, Can´t also rename or duplicate it

Maybe i will better try the "offline" IDE as Ballscrewbob proposes. But I like the advantages of Cloud based coding at these project.

@ Ben84

If you wouldnt mind could you right click on the CREATE bridge icon and select "OPEN DEBUG CONSOLE" before you open create.
It will open a new web page that will mostly be blank when it opens but thats fine.
When you open CREATE itself go directly to PREFERENCES and turn on the following.
Always show output panel.
Console:Show verbose output.

The information from the lower console may also be useful and there is a copy option at the far right on the lower console box.
Use that to copy out the information to post back here.
HEADS UP the information may be too much for the forum to handle so you may have to break it down into smaller chunks or multiple posts.
But please use CODE TAGS ( </> ) as the forum may alter some characters if you dont.

Try out the options that seem to fail and when you have done copy and paste the DEBUG information back here but again please use CODE TAGS ( </> ) as the forum may alter some characters if you dont.

Additional information that may also be useful if you could.

OS version (in windows eg home pro etc) ?
Browser version ?
Security software / anti virus / anti malware currently installed ?

If there is any common theme to the issue add that information too.. EG. I was watching netflix...I also had the regular IDE open to program another Arduino...I was using a bluetooth device... etc.

Everybody has slightly different computer configurations so the development team rely a lot on people like yourself to find and fix bugs that they might not be able to recreate at thier end and they are very quick and responsive to issues like this. (But it is the weekend and they need R & R as much as us LOL)

Bob.