SOLVED: Changed Router - Ethernet shields not working, but Ethernet Arduino does

I recently changed my cable-modem/router to a Ubee DDW36C and all sketches running with ethernet shields lock up on either the Ethernet.begin(mac) call or Ethernet.begin(mac, ip) with a fixed IP.

I thought I'd try an Ethernet Shield 2 and used the assigned MAC, but same problem.
Ran the WebClient and DHCPAddressPrinter examples. Same problem.
Using 1.6.12
Can't ping the assigned IP from the router.
I've tried three shields (1 v2, 2 R3's)

The strange thing is that when I test with an old Arduino Ethernet board (the Uno with the built in ethernet), it works fine. Unfortunately, my main device requires a Mega, so I need to get the shield working.

I have tried everything from this thread.

Any thoughts on why the shield doesn't work, while the board does?

Thanks in advance.

The Arduino Ethernet uses a W5100 ethernet controller. Most Ethernet 2 shields use a W5500 ethernet controller. The W5500 requires a different library.

Thanks. That worked. Still not sure why the old shield doesn't work, but will chalk it up to it and the router not communicating well.