[SOLVED] Chip unresponsive. "not in sync: resp=0x00" Error on Atmega328P-PU

Hello Everyone!

I’ve ordered an Atmega328P-PU uC from eBay and I’m trying to program it. For that I’m using basic connection circuit and FTDI to upload my code. I keep getting the same error (see title). It is just unable to establish connection to my chip.

It seems that I’ve tried everything suggested by google…Here’s what I have tried:

  • Port selected is correct
  • Tried selecting different boards (Uno, Pro mini, DUEMILANOVE and Diecimila)
  • Tried inserting my chip on ARDUINO DUEMILANOVE and it worked fine
  • FTDI works fine because I tried connecting it to my arduino and it uploaded fine
  • Tried connecting pull-ups to RX/TX wires
  • Tried uploading on different versions of arduino IDE (1.0.6 and 1.6.7)
  • Added by-pass caps to vcc
  • FTDI drivers are up to date
  • Double-checked pin connections
  • Tried different usb sockets of my laptop
  • Tried powering my chip with FTDI itself and with external power source

I attached my circuit’s schematic and photo of my wiring.

So at this point I’m thinking that my circuit is at fault and maybe something is missing.

If you could help me solve this it would make me very happy :slight_smile:

Breadboard looks ok, reset pullup, crystal & caps, decoupling caps. Does the chip have a bootloader on it? I would guess not. Yet you say: "Tried inserting my chip on ARDUINO DUEMILANOVE and it worked fine" So that would indicate it does.

Try this - swap the Rx & Tx wires.

Tried swapping them also, didn't help.

Didn't knew whether it had bootloader or not that's why I tried putting my chip into an arduino. On the eBay page it also stated it the chip has bootloader in it.

Are you sure the last pin on the FTDI adaptor board is 3.3V as Usually it is GND. Also what type of capacitors are the mustard coloured ones (not the ones on the crystal) and if they are Tantalum then is the polarity correct?

d137ef8aeb570672693d2b6adcbfa0d8803e310e.jpg

edc599b482fba7c0fa906d1a22d5ddd62a6ebf49.png

Aref should not be connected to Vcc.

I don’t see the pin 13 LED that you use to verify that the chip is actually working with a “blink” sketch (as it would have, plugged into your Duemilanove).

Try removing the two 22 pF capacitors.

Mustard capacitors are ceramic caps, you can find the values in a schematic specified in my first post. I tried disconnecting AREF from 5V, and removing crystal caps. Still same issue…
3V3 is 3V3 and not gnd.
I didn’t connect led because I can’t even upload my code to the chip so I tried removing any unnecessary parts. I tried connecting LED to 19 pin before and it didn’t work also (also checked the voltage for that pin and it always stays constant).

Aref connected to 5 V is not the present problem. It simply should not be connected in any case.

Crystal caps should be marked "22". The breadboard has substantial capacitance itself; sometimes that plus the 22 pF capacitors prevents it from working.

The LED is important. With the chip in the Duemilanove, since it does work, you program and check that the "blink" sketch is working to blink the LED in the Duemilanove.

Then you put the chip in your breadboard and see if the LED with a 470 ohm resistor blinks. If it does not blink, then you know the chip is not functioning at all and you need to figure out why before you even consider attempting to program it in that configuration. At that point, you only have three considerations: power (checked on the chip pins themselves), crystal, and reset connection (actual voltage checked on pin 1 should be Vcc).

[SOLVED]

So I tried putting my chip on a arduino uno. It uploaded the blik program but the blink wasn't working.

I burned bootloader onto my chip and it works perfectly now!

Thanks for your help, guys!