[Solved] Clone arduino Mega 2560 - no serial port DCcduino Mega 2560

Yes - I am like you - reluctant to toss money at someone without even knowing if it is going to work.

Have downloaded the prolific drivers and added an entry to the plist - however it seems the security daemon launches pcsd daemon when it is detected - and I am having 'issues' with my mac when I try to update the securityd plist (to tell it to "Stop doing that!"

Stan

Okdeki - progress (of sorts).

Installed ide on windows-7 laptop.

Plugged in card and the drivers configured without me having to do anything - downloaded modified blink and all worked perfectly.

Went back to ebay and notice that some of the clone boards are UNO's - with the ch340 chip. They give a link to two sites one of which has OSX drivers - (It is is Russia and I had a little twitchiness.......)

Installed that driver (from: http://www.5v.ru/ch340g.htm) and had a port configured.

Still have one issue in that I get the following when I send a sketch to the board - but serious progress is being made.

BTW - as A test I ran the serial monitor - when I type random crud and send it to the Mega clone, I get the serial lights to flash - so basic comms is occurring!

Actually looking at the messages, I think the issue is that because the device name has an imbedded space, AVRdude goes nuts!

The actual device is: /dev/tty.wch ch341 USB=>RS232 fa1240

Stan

Arduino: 1.5.7 (Mac OS X), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Sketch uses 1,518 bytes (0%) of program storage space. Maximum is 258,048 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 8,183 bytes for local variables. Maximum is 8,192 bytes. avrdude: ser_open(): can't open device "/dev/tty.wch": No such file or directory ioctl("TIOCMGET"): Inappropriate ioctl for device ioctl("TIOCMGET"): Inappropriate ioctl for device avrdude: ser_send(): write error: Bad file descriptor

This report would have more information with "Show verbose output during compilation" enabled in File > Preferences.

OK Confirmed it is the command line executed for AVRdude

Captured a verbose output and modified the AVRdude line and put rabbit ears around the port e.g

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega2560 -cwiring -P"/dev/tty.wch ch341 USB=>RS232 fa1240" -b115200 -D -Uflash:w:/var/folders/g7/cb6lb6l107j81ql0bzjzhjf40000gn/T/build2502707317549238769.tmp/Blink.cpp.hex:i

Downloaded Blink, reset the mega and all is good.

So.........................

Now to see if I can request a change in the IDE to rabbit ears the AVRdude port line if the port contains imbedded spaces.

Stan

Okay, drivers for mac do exist. I always see www.wch-ic.com for the driver, but now I searched for "ch341ser_mac.zip" and found www.wch.cn The mac driver is here : http://www.wch.cn/downloads.php?name=pro&proid=178 The version is from wch.cn is a newer, you should try that one.

Hi Peter,

Thanks for your guidance over the weekend which enabled me to get the board up and running.

I have had a look at the source on github and it would be fairly easy to make the change for OSX to encapsulate the device name in double quotes (Rabbit ears) for either all cases or when there is an imbedded space in the device name.

I have raised an issue for this however am contemplating pulling master and making the change on my own system and see if it works - if it does I can investigate feeding the changed module back to github - never done anything with github so a lot of 'learning' required. Also, I am hoping that the OSX project will build in x-code - like I say I havn't done this before!

For the moment however I have a number of workarounds being;

  1. Back out the Russian drivers I loaded yesterday - that will be fun!
  2. Load the drivers you pointed me to - What device did it create on your system BTW?

Another alternative is to make a script up that will rename the device once I have connected and before I load the IDE - don't know if this will work?

Yet another alternative is to make a small shell script up that is specific to the MEGA and points to the existing device and does the AVRDude download.

Finally, on the basis that the card mis-represented itself on ebay is to start a fight and return the card and get a refund of the card and the priority paid postage....... And then get a real mega!

Anyway, once again many thanks for your advice over the weekend.

Stan

In Windows 7 the driver for the CH340G creates : USB-SERIAL CH340 (COM3)
Manufacturer : www.winchiphead.com
and sometimes: Manufacturer : wch.cn
File : 3.30 built by: WinDDK
Name of fysical device: \Device\USBPD0-14

I don’t know if you can return the board. Does the description say something with CH340G ?
You bought a very cheap fake/clone board, and that is what you got.

Final Update.

The drivers at http://www.wch.cn/downloads.php?name=pro&proid=178 work well.

In addition some nano's I had ordered arrived and they use the same chipset - the above drivers work with these as well.

FWIW, it appears a lot of the Chinese clone boards are using this chipset for the USB comms - suspect it is a cheap chip.

Also,

I ordered a genuine mega which arrived - and the original seller of the 'dodgy' mega had sent a new board plus a couple of packets of jumper leads to make me happier.

Got to stop this obsession - I now have.....

1 Uno (Genuine) 3 Nano's (as above) 3 Mega's - one real and two clones 1 Due

(and I confess I also have three itsy witsy tiny ones (plug direct into USB and only have a few pins) coming)

Stan

This problem has resurfaced today. I updated the MAC to yosmite os,.... Now the driver above does not work anymore. Anyone with advice??

The website www.wch-ic.com was down, now it is up, but the drivers are still old drivers. As far as I remember, there were newer Windows drivers, but not newer Mac drivers.

I think you should use linux or Windows. In linux you don't need drivers at all (until they decide to remove it from the kernel because it is almost not used).

I think the CH340G is a good hardware development, but the manufacturer lacks support with good drivers. So I can only conclude one thing: it is a bad product.

It would be better to double the prize and go get en genuine arduino.

Had a problem on OS X Yosemite with CH340G chip. Installed the official driver first - http://www.wch.cn/downloads.php?name=pro&proid=178. This didn't work, so I tried to manually load the installed kext and noticed this error in the console:

20/10/2014 00:43:28.492 com.apple.kextd[19]: ERROR: invalid signature for wch.usb.usb, will not load

After a big of googling found this article - http://www.cindori.org/enabling-trim-on-os-x-yosemite/

Just to summarise. On Yosemite: 1. install the driver 2. Run this:

sudo nvram boot-args="kext-dev-mode=1"
  1. Restart

@dmatyukhin

Thanks for your effort. That did the trick.

mafkaan

Thanks dmatyukhin!!! :slight_smile:

That worked for me YAY

stan_w_gifford: Installed that driver (from: http://www.5v.ru/ch340g.htm) and had a port configured.

Thanks Stan it works for me as well on Win7 64bits

yours Mat

dmatyukhin: http://www.wch.cn/downloads.php?name=pro&proid=178.

http://www.cindori.org/enabling-trim-on-os-x-yosemite/

Just to summarise. On Yosemite: 1. install the driver 2. Run this:

sudo nvram boot-args="kext-dev-mode=1"
  1. Restart

Well - that works only half way through for me. It's highly instable. Though the current driver significantly improves handling as the name is now without spaces. Need to wait for a more stable driver version, though. Thanks for this summary! :)

Drivers are available from the 340 chip manufacturer here: http://www.wch.cn/downloads.php?name=pro&proid=65

They are also built into Linux.

GREAT SHARE. I had been doing OK with my NANOs working till yesterday. Still not clear why after working for days/weeks when others did not my NANO stayed enabled. But in tearing down one circuit to make something new, the port did not come up.

So after making sure of my driver install and still no working port, I read and looked at the entry. But with caution opened the terminal and made the change and yes the Nano is back and running.

@dmatyukhin,

Thanks for the tip, it works!

I bought two of these Mega 2560 from China, the seller provided this driver which works well on the 32-it Macs (Up to OS X 10.7 Lion.) if you use the 64-bit Mac for Arduino development, hate to say you might be out of luck :frowning:

For everyone’s convenience, I uploaded it here as a zip file. Beware, the read me file is all in Chinese! :slight_smile:

CH341SER_MAC_2.zip (252 KB)

Well that was a very interesting few days! :stuck_out_tongue_closed_eyes: For a little while I thought that I was going quietly insane. :astonished: :stuck_out_tongue: But its all fixed now...

I received from an EBay seller a small batch of Arduino Nano ATMega328 boards and ran into this problem immediately. All of the symptoms described by other posters in this thread I experienced. Nothing worked. I must have installed the FTDI drivers dozens of times, but the Arduino Nano would not be seen by my system, a Macbook Air with OS X Mavericks 10.9.5.

It was another thread that gave me the clue - perhaps the Nano doesn't use an FTDI chip at all. And sure enough, it does not.

Etched on the chip are the details; WCH CH340G 2026850406 - so I searched Google for "CH340G" and located this thread at the top of the search.

The Chinese website is very slow and the download of the WCH drivers failed. But thanks to @rich1812 (above) the file he links to downloads very quickly and installs okay in OS X Mavericks.

Be sure to reboot the Mac after installing the drivers.

When plugging the Nano in to the Mac's USB port you can check if the driver has loaded by opening up a terminal and entering the command

ls /Dev/tty.wchusb*

My own device shows up as tty.wchusbserial410

So now I can get on with making use of these cheap Chinese Arduino Nano. Woo hoo!