[SOLVED defective chip] Impossible to upload on new arduino uno (error stk500)

Hello, I have read a lot of topic about sync errors (stk500). But no one helps me to find out about my problem.

UPDATE : I have changed with a working ATmega16u, and I still have got the stk500, so the problem could come from the ATmega32u, could not ?

This is the situation : - Arduino Nano (ATmega328P U & ATmega16u2) - Board and port correctly selected - IDE is up to date - Nothing connected - L LED is always on (never blinking, even after plug/unplug USB) - Driver seems correctly installed. (Device Manager-> Port -> Arduino Uno (COM5)) - Driver configuration is identical to an other arduino driver (which works with another arduino uno (older)) - Uploading log :

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xc6

I thought that it was a bootloader problem, so I did that : https://www.youtube.com/watch?v=UQk8oLreP8E But nothing has changed.

The problem does not come from the cable, my computer, ... Because I have another Arduino Uno (older) that works perfectly.

I really read a lot of about this kind of problems on the forum and I'm not here to write redundant topics.

Tell me if you need more informations. Thank you in advance

Did the Burn Bootloader process complete successfully?

I do not really know if it has completed successfully. The only thing that I can tell you is when I try the Burn bootloader process, the L LED blinks 3-4 times, then it stays on.

And nothing changes when I try to upload again.

Just the RX LED blinks at the same time as I have got the stk500 message (10 times)

In conclusion, I think that it failed.

Is there a way to test if the chip is destroyed?

After you do Tools > Burn Bootloader, the Arduino IDE should either show a teal bar between the editor window and the black console window that says "Done burning bootloader" or else an orange bar that says "Error while burning bootloader". If you get teal bar, that means it was successful.

UPDATE : I have changed with a working ATmega16u, and I still have got the stk500, so the problem could come from the ATmega32u, could not ?

After Tools > Burn Bootloader with Arduino ISP programmer, then I have got this message :

avrdude: Error: Could not find USBtiny device (0x2341/0x49)

This is what I am doing : Examples > ArduinoISP (on programmer) -> Upload (this works) Then I connected pins same as in the video (or Installing an Arduino Bootloader) Then, With the target (plugged) -> Programmer : ArduinoISP -> Burn Bootloader : avrdude: Error: Could not find USBtiny device (0x2341/0x49) If I choose Arduino as ISP programmer, I have got stk500 errors. And I tried with and without letting the wire connected to the pins.

[Fixed] IDE 1.6.9 + ArduinoISP = "Could not find USBtiny device (0x2341/0x49)" error message => Use "Arduino as ISP" Someone is talking about downgrade version of the IDE, ...

When you’re using the Arduino as ISP, you need to select Tools > Programmer > Arduino as ISP. Confusingly, the Tools > Programmer > ArduinoISP is something completely different.

After selecting the “Arduino As ISP” programmer, please do this:

  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Tools > Burn Bootloader
  • After the process fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).
  • Arduino Nano (ATmega328P U & ATmega16u2)

Really? Which one is that? I've never seen a Nano with a 16u2. Genuine Nanos have an FTDI chip; most clones have a CH340.

I have changed with a working ATmega16u

It's not normally a changeable chip! Can you post a picture or something? Perhaps with circles and arrows describing what you've done to it?

@pert I did what you told me. To conclude the ATmega16u2 was just defective. I just sent it back and waiting for a new one.

@westfw Effectively, the ATmega16u2 can not be changeable. I found a seconde arduino uno (which works) so I made a change between the ATmega328Ps. And that's worked. So the problem comes from the ATmega16u2. I copied the memory buffer from the working Atmega16u2 to the defective ATmega16u2, and I do not really know if there is a memory corruption, defective port or something else... But it still did not work. Givent that this chip is not changeable, I just sent it back.