SOLVED: Due not recognized - Windows 10

Hi all,

My Due for some reason can no longer be recognized in Windows. It last worked about 3 months ago when my buddy and I were messing with some base programming. It sat on a shelf since then. Plugged it in last night, the power and a yellow LED come on, but windows doesn't recognize it nor does the programming software.

Software and Windows 10 both only see COM1 for some reason.

Tried holding reset & erase per a thread and that didn't work.

Uninstalled and re-installed the software and due board in the software and that didn't work.

Tried another cable, both ports, and tried on 2 other computers, nothing... >:(

I'd expect Windows to at least make the "new device connected" noise when I plug it in but it does not and does not show up in the device menu.

I've ordered another one in the meantime but looking for assistance getting this to work again. I can't verify the bootloader is loaded, nor can I attempt to re-load since the computer and software won't recognize the Due.

Please help?


1 Like

Assuming you have Arduino Sam Boards (Cortex M3) installed:

Close and restart your PC
Open your IDE window with the minimal sketch (void setup(), void loop()), nothing more.

In Menu > Files > Preferences, select Network, select No proxy
In Menu > Tools > Type of Board, select Arduino Due (Programming Port)
Select the correct socket (near the jack), hook a cable to your PC.
Select a COM port accordingly in Menu>Tools> COM Port (Programming Port)
Compile and upload this minimal sketch.

If this fails, select Arduino Due Native USB Port
Select the USB socket; hook a USB cable to your PC
Select a COM port accordingly in Menu>Tools> COM Port (Native USB Port)
Compile and upload this minimal sketch.

If you still have trouble, disconnect and reconnect the DUE and restart the IDE and if required restart your PC.

1 Like

Error when using programming port:
Arduino: 1.8.5 (Windows 10), Board: "Arduino Due (Programming Port)"

Sketch uses 22084 bytes (4%) of program storage space. Maximum is 524288 bytes.
No device found on COM1
An error occurred while uploading the sketch

Same error when attempting to upload using native port.

My Port menu only has Serial Ports and COM1, nothing more. Windows device manager doesn't show the Arduino at all when plugged into either Arduino USB port.

Pretty sure the issue is that I can't select any port other than COM1 and that leads to my question of why windows won't recognize the board is connected at all.

1 Like

I don't know for Windows 10, for Windows 7 (64-bit): go to Control panel, select peripherals , see if you can update Advanced parameters for the connected Arduino.

1 Like

Thanks, I'll give this a shot tonight

1 Like

no peripherals menu in windows 10. Bought another Due and this one doesn't work either.

1 Like

Just to close this out… turns out the two cables I had were charging only and not for data. That is why Windows didn’t recognize the Due as connected. (I had used my buddy’s cable the first time)

Bought a new cord that stated specifically it could be used for charging AND data and boom, it works.

Thanks for trying to help!

1 Like

I too was making the "Charging only" cable mistake... Very happy to have discovered this thread!

1 Like

So the cable which comes with the Arduino starter kit doesn't work for both data and charging.
My Win 10 is also not detecting the board.

1 Like