[SOLVED] Fail to mount cif drive

I would like to connect my yun to my nas using cif. On my previous project I used the mount.cifs package but I fail to find that in the linino packages. After I installed the cifmount package I get following error:

root@chargeStation:/www/cgi-bin/jantje# mount.cifs nas.local:/linksys /mnt/ -o user=XXXX,pass=XXXX
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

A search on google did not reveal anything that made a bell ring. Anyone has a hint?

Best regards Jantje

I continued to investigate so I installed all packages containing cif ]:D That was samba36-client and kmod-fs-cifs. The last one came with lots of others. Now I get the following error

root@chargeStation:/mnt# mount.cifs /mnt/nas -o user=XXXX,pass=YYYY
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I created the folder /mnt/nas I'm sure the user has the rights and the password is correct. However when I use a wrong password I get the same error.

Anyone has an idea? Best regards Jantje

Mount CIF drive for guest

Mount CIF drive for User:

mkdir /mnt/nas
mount.cifs  //   /mnt/nas  -o user=username,pass=password,sec=ntlm

Thanks The


did the trick. Now I can easily move files from 1 location to another :D Best regards Jantje

Nice one guys: do you mind putting this on the playground page? I'm sure many can take advantage of it