[Solved] Has someone solved problems with Ethernet Shields and TP-LINK Switches?

I am discovering problems with Ethernet Shields and TP-Link Switches. I cannot get a connection to the network, even if the lights on the shield tell me it should work.
But this is only true for desktop switch SF1008 and for the 24port 10/100 SF1024D. At the 24port 10/100/1000 DGS1024 the shields are recognized and working. Same at a FritzBox.
The shields are sitting on a Mega2560 and for testing I use the DhcpAddressPrinter Sketch.

Has somebody any idea to determine if it is the switch or the shield? And how to solve the problem?

Edit: Finally found a solution at this link Ethernet sheild(W5100) not working with Uno - Networking, Protocols, and Devices - Arduino Forum. It seems that ports on different made switches or routers act different against termination resistance. I am surprised that this is the case for 3 different made shields.
Conclusion: If I buy cheap, I have to make adjustments by my own to take it to work properly.