[Solved] Help with: fatal error: arduino.h: No such file or directory

Hello everyone,

I’m pretty sure it’s a stupid mistake I’ve made, but I have no clue on how to fix it.

Can anybody help me with this issue?

Compiling library “OneWire”

“/opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR “-I/opt/cores/arduino/avr/cores/arduino” “-I/opt/cores/arduino/avr/variants/eightanaloginputs” “-I/tmp/webide_tmp473307/libraries/OneWire” “/tmp/webide_tmp473307/libraries/OneWire/OneWire.cpp” -o “/tmp/tmp/webide_tmp473307/sample/libraries/OneWire/OneWire.cpp.o”

/tmp/webide_tmp473307/libraries/OneWire/OneWire.cpp:83:21: fatal error: arduino.h: No such file or directory

#include <arduino.h>

^

compilation terminated.

Using library OneWire in folder: /tmp/webide_tmp473307/libraries/OneWire (legacy)

The OneWire library I got from somewhere on the internet. I can’t remember the address.
It worked perfectly in the desktop IDE (windows)
I made a zip file and uploaded it.

Online it doesn’t want to work anymore.

I tried putting arduino.h in “” but I get the same error.

Thank you very much.

Could you please attach the library here so we can test it? Anyway most of the problems with libraries will be fixed in the next release
Thanks

1 Like

Thanks for your quick answer.

Since there's no way for me to download the library from the online IDE, I will upload it when I get home along with the sketch.

Maybe adding a way to download a library is a good feature. Should I mention this in the dedicated thread?

Thank you.

Libs and sketch are attached.

Thank you.

DallasTemperature.zip (17.5 KB)

LiquidCrystal_I2C.zip (7.95 KB)

OneWire.zip (8.93 KB)

DS18B20_Address_LCD_I2C.ino (2.06 KB)

You just need to change ‘#include <arduino.h>’ in ‘#include <Arduino.h>’ in OneWire.cpp and DallasTemperature.cpp

The option to download a Library will be there in a few releases, we are working on it! Thanks for pointing that out!

@smellai,
Thank you. I'll give it a try when I get home.

@00alis
You're welcome. It's great to see this turning into a great product.

Best regards.

I changed ‘#include <arduino.h>’ with ‘#include <Arduino.h>’.

I’m now getting a different error:
Library can’t use both ‘src’ and ‘utility’ folders. Double check /home/admin/builder/arduino-builder/packages/cores/arduino/avr/libraries/Wire

Whole output is in the attached file.

What am I doing wrong?

Thanks a lot.

output.txt (10.5 KB)

Can anyone please help me with this error?

Library can't use both 'src' and 'utility' folders. Double check /home/admin/builder/arduino-builder/packages/cores/arduino/avr/libraries/Wire

I get this even after I removed the custom libraries.

Thanks a lot.

HI bogdan90211

Can you give me a few details please.

OS and hardware (laptop or full PC) ?
Browser being used and its version ?
Antivirus name or any other specific security / anti malware being used ?
Type of network for the internet being used on the computer with the issue eg. wireless, ethernet etc.
Current AGENT version (see the Arduino Icon in the toolbar and left click. Should be 1.0.43-b199b1a

I would suggest that just for now you keep your own sketches below a total of 10 for a maximum of four boards.

Also keep your custom libraries down the a max of 5 per four boards just for the time being.

If you need to delete sketches then select each board that you use and delete the custom sketches until it is less than 10 for that board. Then do the same for the custom libs keeping them under 5.

Some people have reported success by re-install the Client agent. But if you go that route then you may also want to do a clean up before the re-install.

I use REVO to uninstall set to max, CCLEANER to get rid of the crud followed by WISE REGISTRY cleaner to root out any stray bits. That method is by far the best way to not only remove programs but to do a thorough clean up of your computer too... both CCLEANER and WISE are advert free and work very well.

EDIT ADDITIONAL QUESTION.

Common to a lot of Arduino issues are USB ports and cables. You need to ensure you are on a USB 2.0 port and NOT USB 3.0. If you are using a USB HUB then ensure it has its own power supply capable of meeting all your plugged in devices. Also try other cables as this also seems to be a common issue.

Hello Ballscrewbob,

Thanks for your answer.

I tried on Win7 and Win10, both on full PCs)
I used Chrome and FireFox.
Eset Nod32 Antivirus.
One PC didn't have the AGENT installed. I'll write you the version for the other PC when I get home.

I have only one sketch. No custom libraries.
I'm not sure this is related to the AGENT. I only tried Verify and Save.
I'll give it a new try from a Linux laptop (only Verify and Save) and post the results.

Is there a way to reset the account after I download the sketch?

Thanks a lot.

I am going to concentrate on your win 7 box and chrome as that’s what i run here.

Not 100% sure in NOD (good choice by the way) but there will be a few folders you should add to its exclusions as I know NOD can be a little aggressive in what it lets run on occasion.

The path normally used would be

C:\Users\yourname\AppData\Local\ArduinoCreateAgent
or
C:\Users\yourname\AppData\Roaming\ArduinoCreateAgent

You might also want to add the regular IDE to exclusions too.

C:\Users\yourname\AppData\Local\Arduino15
or
C:\Users\yourname\AppData\Roaming\Arduino15

The programs for the regular IDE may also be worth excluding

C:\Program Files (x86)\Arduino

You will not get CREATE to run without the client agent installed on each PC that uses it.
Don’t forget to click OK if you get a certificate warning. You might get two different warnings and it is OK to accept both of them.

Hello again,

I just got home. The agent version is 1.0.43-b199b1a, just like you said.

I disabled NOD for 10 minutes and I still get the same error.

I'm not sure the error is OS/Machine/Browser related.

The sketch I'm using is attached to an older post if you want to give it a try yourself.

Thanks a lot.

OK what board are you using to upload to please ?

I will try it from here.

From this end the issue is in the code I think.

You may want to double check it to be sure.

I know one of the regular IDE's also had an LCD issue so double check you have the latest lib for it and it is in its correctly named folder. Had some issues in the past where I changed a folder name and the sketch broke. Also try test the LCD on its own first to make sure its good.

Hello,

I uploaded it on a Chinese Nano board using the Arduino software on my PC.
It works OK. I can say the sketch has no build errors since I was able to compile and put it on the board using my PC.

However, I wasn't yet able to built it using Create.
The first issue was related to #include "arduino.h" which was supposed to be "Arduino.h"

After I corrected this, there was a Libraries rework on Create and got the second error:
Library can't use both 'src' and 'utility' folders. Double check /home/admin/builder/arduino-builder/packages/cores/arduino/avr/libraries/Wire

I removed the custom libraries and tried building again with no luck. The last error persists.

My impression is that this is somehow Libraries related. I don't know if this is a general issue or there's something about my account. That's why I asked if there was a way of resetting the account.

Thanks a lot.

Hello,

i can reproduce the Problem by simply adding

#include <Wire.h>

to an empty Project

@ XStyhler where are you placing the define statement ?

It compile just fine here

/*

*/
#include <Wire.h>
void setup() {
    
}

void loop() {
    
}

The error “fatal error: arduino.h: no such file or directory” seems to relate more to actual IDE’s. I don’t know the full answer myself so I am going to point you to a thread that might help.

Or this one.

If you find anything that works please report back with what it was.

This is funny...

Two Hours ago it didn't work, now it compiles just fine.

They often make small changes whilst we are not looking and maybe they fixed it :slight_smile: