[Solved]How to install Arduino IDE 1.0.6 on Ubuntu

Hello,

This feels like a stupid question, but I am quite new to both Arduino and Linux.

When installing Arduino IDE 1.8.3 on Ubuntu 16.04, I simply unpack and run the "install.sh" file that creates the Arduino icon used to start the program.
Now I need to install Arduino IDE 1.0.6. After unpacking I can not find a ".sh" file and are completely stuck on how to start the program.
Can anyone please help me with this?

Just out of curiosity, why the need for such an old version.

Hello sterretje,

I have problems compiling a version of Marlin for a 3D printer, and want to see if i can get it to work in the older version of Arduino IDE. (After someones recommendation on a forum).

No install is needed.

  1. Just unzip the file in your home directory.

  2. Then open the new Arduino folder in your file manager and double (or single) click the arduino file. If double (or single) clicking dosen't work for your system open a terminal and cd into the arduino folder and type ./arduino on the command line and press enter. Should be good to go. You can place a link to the arduino script on your desktop, but don't move the file.

Thank you tf68,

I have tried to double click the arduino file and nothing happens, but when running the file from terminal I am getting an error message "java: not found". I will try again after installing java, guess that solves it.

Yes, the older IDE did not include Java.