[Solved] I can't get my ethernet shield to work

Hi all,

I have been trying to get an ethernet shield to work, but with no success.

I am using a Arduino uno with a Wiznet w5100 based ethernet shield.
Running Arduino 1.6.5 and use the webserver from the examples library. The only modification is the IP address that is set to this is in my home network range for fixed IP addresses.
I also have set port 4 as an output and set to high.

After resetting the board the serial monitor window comes back with the correct IP address, so the SPI interface should be working.

When I open a browser with HTTP:// it comes back with a timeout.
If I ping the address it comes back with no reply.
If I run "advanced IP scanner" it doesn't find the IP address.

The led's on the ethernet shield are PWR=on LINK=on (but goes off when RX comes on) 100M=on FULLD=on COLL=off RX flashes every 1 to 3 seconds and if I try to access the webserver the TX will be flashing.

I have tried 2 different Arduino boards 2 different ethernet shields different cat5e cables and different ports on my switch.
I also tried it with Firefox, Google chrome and Internet explorer.

But all with the same results.

Anyone have any ideas?

Anyone have any ideas?

Does your router know that your Arduino exists, and has that IP address?

Try this test sketch. If your router has a dhcp server, it will display your IP and gateway. That might help troubleshoot your challenge.

#include <SPI.h>
#include <Ethernet.h>

byte mac[] = {  0x00, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };

void setup() {

  // disable SD SPI

  Serial.print(F("Starting ethernet..."));
  if(!Ethernet.begin(mac)) Serial.println(F("failed"));
  else {

void loop() {

Hi, Thanks for your replies.

To PaulS : I just have a simple network switch between my computer and the ethernet shield, normally I can see everything in the range to everything above is available for DHCP allocation.

To SurferTim : I tried your test sketch, it starts with "Starting ethernet..." then after a minute or so "failed"
I still see the RX and TX led's on the shield flashing like it is trying to communicate but no luck.

Have you tried that last sketch connected directly to a router (no switch between them)?

Hi SurferTim, I got your post just before I was going to post this update, you where on the right track.
Thanks for your help.

UPDATE : after reading PaulS reply, I realized that the only component in the chain that wasn't changed yet was my network switch. After changing the network switch for an other one I had, everything came to live and ending 3 weeks of frustration.

Somehow the ethernet shield and my network switch are not compatible.

Both shields are working perfectly now.

I gained an experience and a paper weight. :wink:

Thank you.
You solved my big problem ..
I have the shield W5100 and my router only supports DHCP
Now I will pick up the Webserver sketch and adapts it.
Once again thank you

Hello NZJohn, what type of switch works with Your ethernet shield? Brand, model etc.. And what "type" of ethernet shield do You have? I mean markings from han-run sticker. Thanks!

I have found switch which works with w5100 - netis model no ST315S