[SOLVED - IDE update] Did I mess my bootloader ?

Hi eveyone,

After trying to burn the bootloader of an Arduino with another, I tried to upload a sketch on a Nano and received the following error: avrdude: no programmer has been specified on the command line or the config file Specify a programmer using the -c option and try again

I believe I forgot to change the Programmer and let the "Arduino as ISP" while doing my upload.

Any choice in the Programmer menu leads to the same error. Would you have a solution?

Thanks in advance

Unless you did "upload using programmer", the tools -> programmer menu is ignored, and tries to upload via serial (except for boards that don't support serial uploads - but that's not the case for the nano.

Do you have something selected in tools -> Ports? You need to select the serial port from that menu.

That error has nothing to do with the hardware - avrdude is refusing to do anything because the command the IDE called it with is invalid.

Enable verbose upload and try again - that will give you the text of the command it's sending, which you can post so we can get an idea of what's going on.

Thanks for your answer.

I may have used "Upload using programmer" at some point looking for a solution. In Tools > Port, it uses the USB serial.

Regarding verbose, the terminal reads:

vrdude: Version 6.0.1, compiled on Apr 14 2015 at 16:30:25 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf" User configuration file is "/Users/Olivier/.avrduderc" User configuration file does not exist or is not a regular file, skipping

avrdude: no programmer has been specified on the command line or the config file Specify a programmer using the -c option and try again

There is indeed no such file .avrduderc in the directory, but not either in the computer.

Please include the whole message. The line I need is a couple lines up from what you posted (it shows the actual command line that the IDE tried to use, and which avrdude reports is valid.

The user configuration missing message does not indicate a problem - the system-wide configuration is all you need.

Sketch uses 8,754 bytes (28%) of program storage space. Maximum is 30,720 bytes. Global variables use 483 bytes (23%) of dynamic memory, leaving 1,565 bytes for local variables. Maximum is 2,048 bytes. /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v true -patmega328p -carduino -P/dev/cu.wchusbserial1410 -b57600 -D -Uflash:w:/var/folders/zr/0brq7djn1lg0cpp5gqq0kxrh0000gn/T/buildbec0971f1d872dc17a8b9c8226bcfc6e.tmp/Oswald_WIP.ino.hex:i

Should I include also the previous bulk?

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v true -patmega328p -carduino -P/dev/cu.wchusbserial1410 -b57600 -D -Uflash:w:/var/folders/zr/0brq7djn1lg0cpp5gqq0kxrh0000gn/T/buildbec0971f1d872dc17a8b9c8226bcfc6e.tmp/Oswald_WIP.ino.hex:i

Well that's strange! the programmer is being specified: -carduino just as it should be.

No clue.

If you are using the 1.6.8 IDE then down- or upgrade your arduino IDE

That solved mine problem

The upgrade indeed solved the problem. It feels great to be back discussing with the boards! Thank you DrAzzy ans Sikko!

I have the same problem and the new install didn't help at all (1.6.9):

avrdude: Version 6.0.1, compiled on Apr 14 2015 at 16:30:25
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Users/alkopop79/Downloads/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/alkopop79/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.usbserial-A70075GX
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

What am I doing wrong?

Halle everybody! Thanks for the solution guys!

@ alkopop: maybe it’s easy:

alkopop79:
I have the same problem and the new install didn’t help at all (1.6.9):

avrdude: Version 6.0.1, compiled on Apr 14 2015 at 16:30:25

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

[code] (… etc…)

What am I doing wrong?
[/quote]

I had the same Error with my brand new mega 2560:  “avrdude: no programmer has been specified”  that I just solved with the update to 1.6.9. I saw this new errors but in my case was just my mistake: I had to set the Arduino Mega in the IDE instead UNO. (and i still doing it whe i switch from the mega to the UNO) Did you checked that? Maybe you did my same mistake and it’s a matter of exactly two clicks!! :slight_smile:
Good luck and regards to everybody

I was having the same problem (avrdude: no programmer has been specified...), here are my findings:

avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v true -patmega328p -carduino -P/dev/cu.usbmodem1451 -b115200 -D -Uflash:w:/var/folders/ql/msh5c8sn28v6t32m63f_3dyh0000gn/T/build02b63125bf4d313a6b015d6bf03cb2ad.tmp/Fade.ino.hex:i

The command line constructed by the Arduino IDE is malformed, the -v argument doesn't take a parameter. If you remove true that follows it it'll work as expected. My Arduino IDE is 1.6.7 so I don't think this problem is specific to one version of the IDE. I was thinking maybe avrdude used to just ignore it but a recent update changed that (which could explain why we seem to be having this problem now) but the latest update was last December and I don't remember updating it recently so I'm at a lost as to why it used to work.

In any case, I just updated to the latest version 1.6.9 and the IDE doesn't write true after -v anymore.

@alkopop79: The problem you're having is different. avrdude dude isn't failing because it can't make sense of the command line but because it is not able to talk to the board. Check to make sure it's using the right port, the serial monitor isn't open in other Arduino IDE window and that nothing is connected to your board UART (Serial) pins is connected to (or first one if you board has multiple). This is usually pin 0 and 1.

I just ran in to this and with the help of this thread I solved it... Turns out its the recent AVR boards lib update! Downgrade your AVR Boards file to 1.6.8 (I'm on IDE 1.6.8 so this made sense) Et voila... all better, thought it was strange as it worked a couple of days ago.

I was reprogramming a FIO when I ran in to it, with other boards your mileage may vary!

S

samlight: Downgrade your AVR Boards file to 1.6.8 (I'm on IDE 1.6.8 so this made sense)

This may be a dumb question. How do you downgrade the AVR Boards file??

Tools -> boards -> Board Manager

The versioning on the AVR board package is not the same as the IDE versioning. The both started at 1.6.0 but the AVR boards package has had a few more releases in the meantime. It's stupid, but not half as stupid as their not testing 1.6.10 before release.

1.6.11 of the AVR boards and 1.6.9 of the IDE is what I currently recommend - 1.6.10 IDE and 1.6.12 AVR boards (that's what 1.6.10 IDE comes with) have major problems.

DRAzzy your a life saver, went back to ver 1.6.9 all is well again THANKS

Help… tried all the random ‘solutions’ above, no luck, using Arduino1.8.0 and still the same problem ‘…configuration file does not exist…’ and that baud rate is all wrong.
downgraded AVR boards to 1.6.11 but still the same error message. Why does the error message refer to a programmer? I’m using an iMac with OS 10.12.2 but I also tried my old PowerBook G4, same problem. Is no one fixing the downloadable stuff anymore? Should I try the web version?
Can anyone explicitly steer me to the correct versions please?

Thanks, your novice Arduino hacker.

avrdude: Version 6.3, compiled on Dec 16 2016 at 13:32:25
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf”
User configuration file is “/Users/Honders/.avrduderc”
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/cu.usbmodemFA131
Using Programmer : arduino
Overriding Baud Rate : 115200
AVR Part : ATmega328P
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PC2
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 20 4 0 no 1024 4 0 3600 3600 0xff 0xff
flash 65 6 128 0 yes 32768 128 256 4500 4500 0xff 0xff
lfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
efuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
lock 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : Arduino
Description : Arduino
Hardware Version: 3
Firmware Version: 4.4
Vtarget : 0.3 V
Varef : 0.3 V
Oscillator : 28.800 kHz
SCK period : 3.3 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f (probably m328p)
avrdude: reading input file “/var/folders/rg/4r60n2_s0zj6rpzy3lg79hbm0000gn/T/arduino_build_650448/RPM_ROTORK_VALVE_CONTROL.ino.hex”
avrdude: writing flash (4516 bytes):

Writing | ################################################## | 100% 0.74s

avrdude: 4516 bytes of flash written
avrdude: verifying flash memory against /var/folders/rg/4r60n2_s0zj6rpzy3lg79hbm0000gn/T/arduino_build_650448/RPM_ROTORK_VALVE_CONTROL.ino.hex:
avrdude: load data flash data from input file /var/folders/rg/4r60n2_s0zj6rpzy3lg79hbm0000gn/T/arduino_build_650448/RPM_ROTORK_VALVE_CONTROL.ino.hex:
avrdude: input file /var/folders/rg/4r60n2_s0zj6rpzy3lg79hbm0000gn/T/arduino_build_650448/RPM_ROTORK_VALVE_CONTROL.ino.hex contains 4516 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 0.59s

avrdude: verifying …
avrdude: 4516 bytes of flash verified

avrdude done. Thank you.

OK - Guess I was just being anal - did not like seeing the red print scrolling by. It did not have any effect on anything, the program uploaded fine and even did what it was supposed to.

To hide the upsetting error messages go to Preferences under Arduino and uncheck the two boxes after 'Show verbose output during:" . Forget about the missing file, I could not find it until FiveStar Nick explained that you need to select the Arduino app and right click to see the menu, etc.

That should make your world all pretty again when you upload. Whew! that only took up half my day, and there was nothing wrong with anything except the error messages. Happy coding, Rob

Thank you for this. I was freaking out too.