[SOLVED] — IDE Won't launch any more (Mac OS 10.15.5)

Hi

My IDE started behaving strangely tonight, getting frozen and then not launching anymore.

I tried to look at preferences etc but did not see anything weird.

I ended up

  • trashing the App
  • removing any defaults that had to do with cc.arduino.Arduino
  • removing the ~/Library/Preferences for Arduino
  • deleting “Arduino15”
  • rebooting my computer.

Then I downloaded a fresh version(1.8.12) of the IDE from the web site, installed it and launched.
All went fine.

I wanted then to install the ESP32 environment, so went to add “https://dl.espressif.com/dl/package_esp32_index.json” in my preferences (through the user interface)

I quit the IDE.

I try to relaunch the IDE → it dies…

I did not change anything else than providing this URL for the packages.

Launching from command line in Terminal, after complaining about a few fonts it dies too with

java.lang.NullPointerException
	at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(ContributionsIndexer.java:134)
	at processing.app.BaseNoGui.initPackages(BaseNoGui.java:483)
	at processing.app.Base.<init>(Base.java:273)
	at processing.app.Base.main(Base.java:150)

and looking in the system console I see

par défaut	02:21:08.065850+0200	kernel	AGC:: [Arduino pid 15025 mux-aware] exiting, non-mux-aware app count 0, runtime: 0:00:02.057
par défaut	02:21:08.066613+0200	hidd	Connection removed: IOHIDEventSystemConnection uuid:3BC68654-7906-4F8D-9BFE-60A48F203C4A pid:15025 process:Arduino type:Passive entitlements:0x0 caller:HIServices: ___GetIOHIDEventSystemClient_block_invoke + 26 attributes:(null) state:0x1 events:0 mask:0x0
par défaut	02:21:08.066725+0200	hidd	Connection removed: IOHIDEventSystemConnection uuid:B2421158-DE7C-42D8-BD7F-6F72FBB06F19 pid:15025 process:Arduino type:Passive entitlements:0x0 caller:HIToolbox: ___GetIOHIDEventSystemClient_block_invoke + 26 attributes:(null) state:0x1 events:0 mask:0x0
par défaut	02:21:08.070317+0200	runningboardd	Invalidating assertion 274-127-530 (target:executable<Arduino(501)>) from originator 127
par défaut	02:21:08.087367+0200	runningboardd	[executable<Arduino(501)>:15025] Death sentinel fired!
par défaut	02:21:08.100552+0200	runningboardd	Invalidating assertion 274-127-529 (target:executable<Arduino(501)>) from originator 127
par défaut	02:21:08.100713+0200	loginwindow	-[PersistentAppsSupport applicationQuit:] | for app:Arduino, _appTrackingState = 2
par défaut	02:21:08.100739+0200	loginwindow	-[PersistentAppsSupport applicationQuit:] | App: Arduino, quit, updating active tracking timer
par défaut	02:21:08.178246+0200	runningboardd	[executable<Arduino(501)>:15025] Ignoring jetsam update because this process is not memory-managed
par défaut	02:21:08.178369+0200	runningboardd	[executable<Arduino(501)>:15025] Ignoring suspend because this process is not lifecycle managed
par défaut	02:21:08.178545+0200	runningboardd	[executable<Arduino(501)>:15025] Ignoring GPU update because this process is not GPU managed
par défaut	02:21:08.191975+0200	runningboardd	Removing process: [executable<Arduino(501)>:15025]
par défaut	02:21:08.192300+0200	runningboardd	Removing assertions for terminated process: [executable<Arduino(501)>:15025]

in the log there is this weird

02:21:08.087367+0200 runningboardd [executable<Arduino(501)>:15025] Death sentinel fired!

Anyone seeing the same ?

OK - after more fiddling around, I had not deleted my Arduino folder with all the tools and libraries etc.

I removed it and started fresh there too and I'm back in business.

I don't know what was wrong in the end, probably a corrupted file somewhere in there.