[SOLVED] #include <AFMotor.h> compiling error

Hello,
I am coding with DC motors for an Arduino Uno. When I verify the code it says compiling error (I have indicated a description of the compiling error below). However, after debugging a little bit, I believe there is a problem with this part of the code: #include <AFMotor.h>

The motor shield that I am using is from this website.
I would really appreciate if someone could help me.

Thank you very much!

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Thank you for pointing out the fact that I was using the adafruit version. Here is my code. The objective of this code to have a sumo robot that would be able to attack and defend itslef in fight against other robots. I am still working on it however I wanted to verify whether it was working so far. Unfortunately, it keeps showing the compile error. Furthermore, as far as I am concerned it seems to be happening with almost any library that I am trying to import.

#include <Motor.h> //import the motor library    
#define trigPin 12 //the transmit signal pin for the Ultrasonic sensor 
#define echoPin 13 //the pin that recieves the echo for the Ultrasonic sensor
int maximumRange = 500; // Maximum range needed
int minimumRange = 0; // Minimum range needed
long duration, distance; // Duration used to calculate distance
DCMotor motor1(1,MOTOR12_64KHZ); // set up motors 
DCMotor motor2(2, MOTOR12_8KHZ);
}
void setup() {
 // put your setup code here, to run once:
motor2. setSpeed (200)
motor3. setSpeed (200)
pinMode (1,INPUT_PULLUP)
pinMode (2,INPUT_PULLUP)
delay (3120);   
Serial.begin (9600);
pinMode(trigPin, OUTPUT);
pinMode(echoPin, INPUT);
}
void loop() {
 // put your main code here, to run repeatedly
/* The following trigPin/echoPin cycle is used to determine the
distance of the nearest object by bouncing soundwaves off of it. */ 
digitalWrite(trigPin, LOW); 
delayMicroseconds(2); 

digitalWrite(trigPin, HIGH);
delayMicroseconds(10); 

digitalWrite(trigPin, LOW);
duration = pulseIn(echoPin, HIGH);

//Calculate the distance (in cm) based on the speed of sound.
distance = duration/58.2;

 if (distance >= maximumRange || distance <= minimumRange){
/* Send a negative number to computer and Turn LED ON 
to indicate "out of range" */
Serial.println("-1");
 }
else {
/* Send the distance to the computer using Serial protocol, and
turn LED OFF to indicate successful reading. */
Serial.println(distance); 
}

//Delay 50ms before next reading.
delay(50);
}

When I say “almost”, this problem has been happening with every single library that I am trying to import. I haven’t tried importing every single one of them but the ones that I have imported are showing this error.I have indicated the error below. Thanks for the help!

F:\Arduino\Sumo_Sketch\Sumo_Sketch.ino:1:50: fatal error: Motor.h: No such file or directory

#include <Motor.h> //import the motor library    

                                                 ^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

I was guessing that was the issue as well. I tried going to menus and doing what you suggested before. However, I believe that I was suppose to download the libraries so I did that, and I needed the motor library. So i tried downloading it form here
http://playground.arduino.cc/Code/Motor but the file was empty. So that’s where I am stuck. Is there a another way to download the motor library? Or maybe I was doing it wrong because there is no "import library"like suggests on the website, instead there is the insert library so when I tried doing that it says that the zip file is empty.

adam08: it says that the zip file is empty.

I confirm that. The file is 0 bytes. I can't find the library anywhere else and that Playground page hasn't been updated in 7 years so I think you might need to give up on using that library. There's nothing to indicate that library would even work with your hardware. You might instead use the example sketch provided by SparkFun on the product page: http://cdn.sparkfun.com/downloads/Ardumoto/ardumoto_example.ino

adam08: there is no "import library"like suggests on the website, instead there is the insert library

Those instructions were written for an old version of the Arduino IDE. The menus have changed since then.

Thank you very much for your help! I appreciate it. I will try to do it without the library.