SOLVED: Incredibly long IDE startup time - over 3.5 minutes

IDE 1.8.13,
OS Windows10 20H2
CPU 6-core AMD Phenom || X6 1100T 3.3GHz 16GB RAM

I have started getting insane startup times. SOMETIMES (If I could pin it down i wouldn't be here :slight_smile: ) It takes 30 seconds between click and IDE window available, but in the last few days, 9 times out of 10 I get 3.5 minutes plus. When I get this slow start, it is consistently 3:30 to 3:40.

Nothing is maxed out, I have removed all but 9 libraries. I am using the ESP8266 core 2.7.4 - I have had this setup for many years, moving up through all versions of the IDE...I have never had a problem before with slow loading.

What on earth is causing this? No, disk activity, no net activity...

Antivirus?

I'm using AVAST - same as last few years with no problems PLUS I have excluded libraries and core folders from AV

Your screen shots show you should be looking at all the other tasks that are running and see which one/ones are active.
Paul

Why? They are obviously not affecting CPU performance nor memory usage, therefore what possible effect could any of them (whatever they may be) have on the slow loading? If you know of specific other tasks which CAN cause problems, I'd love to hear, or is your comment just a general-purpose guess?

Assuming I look at the other tasks, what next - you tell me "its probably one of them" ? The same tasks that have been running for years on this box WITHOUT causing problems?

I'm looking for concrete suggestions as to what might be causing the problem and/or what further diagnostics I can provide to someone who knows about the IDE.

A couple of things you might try for diagnostic purposes:

  • Run the Arduino IDE in portable mode to isolate it from the normal sketchbook and data folders.
  • Start the IDE with your computer disconnected from the Internet to prevent it from querying builder.arduino.cc for identification of your connected boards.

There you go, making assumptions.
When my computer slows way down, something like Microsoft is downloading an update or a program that is never run, but always started when the computer is booted up, begins to run and look to see if it is supposed to be updated. If you never look, you will miss them.
Paul

Well apart from YOU being the one making assumptions rather than offering actual suggestions, IU didn't understand a word of "or a program that is never run, but always started when the computer is booted up, begins to run and look to see if it is supposed to be updated"

So thanks for trying, but really, please: no more. I find your answers totally unhelpful.

OK will try both of those and get back to you. Thanks.

Bizarre. Disconnected network, started in 9.74 seconds. I reconnected network, started again about 2 minutes ago, its still on the splash screen as I'm typing.

So what does this tell us?

There are several possibilities I can think of for why:

  • Accessing a path on your computer that is hosted on a cloud service (e.g., OneDrive, DropBox) or network drive. Using the IDE in portable mode would eliminate that.
  • Querying builder.arduino.cc for the board information associated with the USB VID/PID. Disconnecting from your computer all Arduino boards and any other USB devices you are able would eliminate that. From the screenshot you shared, I can see you had a CH340-based device attached to your computer.
  • Downloading the Boards Manager or Library Manager index files. I haven't seen reports of this causing a startup delay before.

This is nuts, it's making it unusable - 6:37 to load!!!! Nothing major has changed here since last week when this had all been working for literally years...apart from a big Win10 upgrade to 20H2. My ISP is the same, router, network etc etc all the same as last week. Is it relevant that I alsi installed the new IDE beta a few days ago to evaluate? :slight_smile: :slight_smile: :slight_smile:

I have nothing on any cloud devices. When I disconnected the board, I got a 7+ minute load time, so I don't buy your second suggestion.

What's the relevance of the CH340? Its the same device I have had attached for many months withiut any of these problems. I cannot reiterate enough how this is 95% the same setup that has been working for years.

It's not only a matter of "here". We live in a connected world. We've already identified the problem seems to be somehow related to a connection to the network, so there's also a lot of "there" that could be involved. Even if everything stays the same on your computer, if there is some external component that changes, that can affect what happens on your computer.

Look, I'm just trying to brainstorm to help you diagnose this problem. If I had the answer, I would have given it to you.

FYI IDE 2.0.0-beta.5 just loaded in about 20 seconds with network connected. With CH340 device reattached + network connected, same 20 second load time. Is there some issue with the Arduino.cc servers ? What kinda software waits 3 - 6 minutes before calling a timeout anyway? But more importantly, why has it only just started and how do I stop it ?

My apologies: when I saw "Arduino Team" - I thought that meant you were part of the dev team. Yoiur brainstorming is defintely moving the issue forward so do please keep making suggestions!

Seems like there may be a problem with the builder server - but strange thats its only a problem for me :frowning: Also, going towards ruling out the driver link: I tried a different board with a CP2102 driver - same crazy multi-minute start time.

FYI total remove / reinstall 1.8.13 - same behaviour :frowning:

Solved. The preferences.txt file was 60kb+ with 672 sketches named under the recent_sketches key, some going back literally years... plus version history going back to 1.6.5 installation...

Recently I have been editing / renaming a lot of sketches in readiness for a release of my new firmware so maybe I tipped something "over the edge". I also noticed some decidedly dodgy settings at the end that looked corrupt... I basically hacked out anything old or dodgy looking , taking it back down to 5k....

IDE loading in sub 5 seconds even when net connected. This is DEFINITELY a bug in the preferences.txt handling.

I'm glad to hear you solved it!

The bug with the recent_sketches key has been reported here:
https://github.com/arduino/Arduino/issues/10963