Solved: Installation of CH340 driver fails

After years of successfully working with my Arduino Nano with CH340 chip, now it is not possible to upload any sketch. I am not sure but I believe the problem exists since “new boards available” had been poped up and I installed new boards version 1.8.3 for AVR boards.

The first which worried me was that for selection of a port only COM1 was available. Formerly it was “COM8 Arduino Nano”.

Trying to upload a sketch ends with messages

...
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x92
...

In the forum here there are many postings reporting this type of error. And there are tips to install the CH340 driver.

Therefore I downloaded at first CH341SER.EXE and ran it without success, i.e. there was no reaction at all, no window popping up, etc…
Then I downloaded CH341SER.ZIP, extracted the files to my programs folder “…\arduino-1.8.13\drivers\CH341” and ran SETUP.EXE which also was contained in the zip file.

At first clicking UNISTALL, driver uninstall was confirmed: hi, what’s that, the driver was installed?
Then clicking INSTALL, and “The drive is successfully Pre-installed in advance” was confirmed.
Try to upload a sketch, same problem as described above. I tried with ATmega 328P and with ATmega 328P (old bootloader).

Now clicking on HELP (in the setup.exe window) shows the following text:

Setup program overview
1. You should put all the drive files(sys,dll) in the same directory at first, then select the installation file *.inf before installing or uninstalling the driver;
2. Run the 'setup.exe' file and click [INSTALL] to install it in advance. If the device is inserted, the system will find the new device and clue it on. Click 'next' to complete the process;
3.Insert the device, run the setup.exe, and then click [INSTALL] to install device driver;
4. Click [UNINSTALL] to unistall the device driver;
5. Delect the driver file by [!! Delete the...]. Because the driver files are shared by other devices, Delete it will lead that other divece can't work;
6. Install the drive in the command line box. Type 'SETUP /S' to install driver and type 'SETUP /U' to uninstall the driver. there are not any dialogbox appeared;

Really, I don’t fully understand the complete poorly translated English. But I tried to follow the proposed steps and stopped in step 2 because there is no ‘next’ to click on.

Further I tried various sequences of INSTALL and UNINSTALL without success. Trying to upload a sketch always ends with the error messages above.

What shall I do to successfully install the CH340/341 driver on my Win10 PC?
(The USB cable is ok, it works with other hardware)

It’s much more likely that you fried your Nano.

Do you see a new device appear in the Windows Device Manager device tree when you plug the USB cable of your Nano into your computer?

Really, it looks like a defect Nano.
Two other Nanos, also with CH340 chip, are working, and the device manager shows “USB-Serial CH340 (COM4)”.
Thank you for the tip with the device manager.